Deploy mode

Hi All,

 

I have deployed a model from development to Production and try to run a script for batch run from other source in production environment, the script was run successfully but data is showing blank?

 

And when i tried to upload the same file manually in production, i am getting error as "Deployed ode is enable for this model. you do not have permission to change structural data:

 

Can someone suggest in this issue?

 

Shweta_0-1653565054922.png

 

Best Answer

  • alexpavel
    Answer ✓

    @Shweta : how are you trying to upload the file?

     

    In order to check if the import action it's working OK, you need to publish the import action in a classic dashboard or a NUX page and push the button to upload the file.  This way you will verify that the import action as "run-time" mode. 

     

    If you try to upload the file, like when you created the import action, indeed, it will appear that this is a structural modification, as you try to modify an import data-source that is, by default, not a "production data".  

Comments

  • Hi @Shweta,

    What is the target of this import? If it's import to a list that is not marked as a production list, it cannot be updated in a model that is deployed. You need to go to DEV, mark it as Production data in list's settings, and only after syncing this change to production you will be able to modify list in deployed mode.

    If above is not a case, to help you I'd need more details about the import, it's source and target.

  • @Shweta  as @M.Kierepka  mentioned, this message usually appears when, in a deployed model, it is launched an import action that tries to create elements in a list that it's not flagged as "Production list".

     

    It is needed to be familiarized with what does it mean "production data" and "production lists"

     

    A starting point could be this:

    https://help.anaplan.com/7b886afc-f1d8-498b-a609-aa9d7130a9aa-Application-Lifecycle-Management-Overview

     

    To solve this, it is needed to go in DEV model and flag the list as "production list" and push into PROD model the modifications and re-try to launch the import action. All the lists that you want to be automatically updated using import actions should be flagged as "production lists".

     

    Hope it helps

    Alex

     

  • Hi Alex & M.kierepka,

     

    Thanks for your email, it helps me for the list import but, my issue is related to data import in module which is integrated through Action setting from different source via API connect.

     

    Hope i am able to explain my issue now!

     

    Regards

    Shweta

  • Hi @shweta.arora/@Shweta ,

    But does it occur only if is run via API? This kind of errors shouldn't be dependent on how you upload a file (via API or browser). Can you share the settings of this import action? Screenshot of view that you see if you click "edit import" button - if import file is no longer available, please reupload it.

  • @Shweta 

     

    Quick question, is the name of the file you are trying to load the exact same as it was defined in Dev?

  • Hi Alex,

     

    I am now able to import the data via batch run (API connect) but now the issue is different:

    I have created a 2 versions (Budget and Actual) and year as FY20,FY21 and FY22 and now when we run the script the data is coming only in version budget and in FY20, but i want this data in Actual FY22

     

    I am attaching the screen shot 

    shwetaarora_0-1653983816136.pngshwetaarora_1-1653983838945.png

    In the above screen shoot, you can see the data is visible in FY20 but blank in all other.

    Am i missing any step?

     

    Regards

    Shweta