How to remove arrows from column headers on a dashboard

I'm trying to publish a table to a dashboard and I'm getting this weird problem with the sort option. For some reason there is a small arrow in the column header, but I don't want it there. I've tried republishing the module to the dashboard with no success. I also tried removing the sort, saving and refreshing, and then re-adding the sort but the arrow always comes back. The picture labeled arrow is the one on my dashboard and the one labeled no arrows is the view I have saved for my module. You can see that the module is what I'm looking for, but the arrow immediately appears when I post it to the dashboard. Can someone help me remove this arrow while keeping it sorted?

Tagged:

Comments

  • If I'm understanding you correctly, you want to sort the grid, but not have a visual indicator of the sort. To my knowledge, this is not possible. I also think it provides a poorer user experience if you were to hide the sort. Is there a reason you don't want end users to know the data is sorted?

     

    The only other way I know of to order data without a sort applied is by using an Order List Action to reorder the list itself.

  • The cheeky alternative (at least in old UX) is to create a separate line to act as the sort field and don't publish it to the view. You'd need to show the line, apply the sort then hide the line and save the view.

     

    We do this anyway because the sort criteria/line isn't usually relevant for the end user, at least in our use cases.

     

     

  • I would strongly encourage you to start using the UX for many reasons, one of them being the end user can easily turn off/on sort as they wish using right click menus.

    ChrisStauffer_0-1655308098809.png