Unable to load special characters using .CSV file

I am unable to load special characters in Anaplan using an import where file is the source. 

Kindly note the following:

1) Import is setup with text encoding set as UTF-8

Shraddha0706_0-1663530439904.png

2) The format of file that is being loaded is .CSV

Shraddha0706_1-1663530481608.png

 

Following is the text i am trying to import and the text that is getting loaded in Anaplan:

To ImportAfter import
Tést is yet für away. 

T�st is yet für away.

 

Please help..!!

Comments

  • JaredDolich
    edited December 2022

    @Shraddha0706 

    You may need to normalize those characters.

    Start by reading the entire Anaplan technical spec on special characters here. Not too long - has great links.

    Normalization - Unicode equivalence. Just be weary of characters that are not supported.

    Also, you can contact your business partner. They will have direct access to the technical team at Anaplan. I suspect your question isn't the first time it's been asked.

  • harshitha.narayan@sony.com
    edited December 2022

    Hello @Shraddha0706 ,

     

    I would suggest you to cleanse the file first.

    For example if your initial file is a Excel file, apply CLEAN formula on those cells and convert / save it in "Unicode text" file format and try to import this file into the module.

     

    See if that works.

     

    Thanks,

    harshitha 

  • M.Kierepka
    edited December 2022

    Hi @Shraddha0706,

    You are picking wrong option when saving CSV in Excel. You should pick "CSV UTF-8 (comma delimited)", which is 5th from the top on your screenshot. Instead, you are saving it as just "CSV (comma delimited)", 5th from the bottom, which is being saved in user-dependent ANSI encoding, and that's why when imported to Anaplan, it does not map to UTF-8.

    MKierepka_0-1663751755819.png

     

  • Shraddha0706
    edited December 2022

    Hi @M.Kierepka

     

    Thank you for your solution. This has solved our issue. 

    Appertiate your help..!!