Clarity with Anaplan API

Hi,

We are trying to make a custom API call for running an Import in Anaplan using a connector that calls the custom API. When we try to look at the URL used for the API call , it starts as 

''https://api.anaplan.com/2/0/workspaces/' -> I could conclude that 2/0 here means version 2.0, but this keep running into authentication error or the resource not exist, although we have checked the access multiple times.

 

When I compared this with python script based API, that start with a different call

''https://api.anaplan.com/1/3/workspaces/' -> This works perfectly, but even if I change it to 2/0 , it runs into same error.

 

Unfortunately, the connector which we are using doesn't give us an option to change from 2.0 to 1.3 . Can anyone suggest any possible solution to this?

Any help is appreciated.

 

Thanks and Regards,

Aakash Sachdeva

Comments

  • Hi @aakash,

    Are you sure you are using Anaplan Authentication API before trying to connect to API V2? This is the main difference between 1.3 and 2.0:
    - with 1.3 you are sending email+password with every request (and you do it, so it works for you)
    - but with 2.0 you only send it once to Authentication API, you get a token in return, and then you use this token to use API 2.0.
    That's why you get "Not authenticated" message with 2.0 - you are sending email+password with request, but API is expecting a token from Authentication API.