Importing file into flat lists

kunal_311
Frequent Contributor

Importing file into flat lists

I was trying to import data from country CSV to a country flat list.

but since the format of the source file was such that parent needs to be entered while importing or else it is throwing error.

Due to which imported data comes as hierarchy and not as flat list.

Please help with this.

1 ACCEPTED SOLUTION

Accepted Solutions
einas.ibrahim
Master Anaplanner/Community Boss

Hello @kunal_311 

By definition, a Flat List doesn't have a parent. If you are importing into the list shown in your file LVL 2 FLAT.jpg then you are importing into the wrong list.
Scroll down the list page in your model until you see the separator ----Flat Lists ----, these are the Flat Lists to which you should be importing the data from the csv files.

Later on, you will use a process to build the hierarchy Region > Country > Location

 

image.png

Einas
"Give a Man a Fish, and You Feed Him for a Day. Teach a Man To Fish, and You Feed Him for a Lifetime"

Dear community members
Consider posting your question as a new topic and not in the thread of another topic/question. This help other community members to easily find the answer they looking for and doesn't cause the original thread to be so cluttered that we can't find what we are looking for

View solution in original post

8 REPLIES 8
Misbah
Moderator

@kunal_311 

 

What error are you getting? In order for you to create a flat list you need to ignore mapping for Parent and map Code and Name.

einas.ibrahim
Master Anaplanner/Community Boss

Hello @kunal_311 

By definition, a Flat List doesn't have a parent. If you are importing into the list shown in your file LVL 2 FLAT.jpg then you are importing into the wrong list.
Scroll down the list page in your model until you see the separator ----Flat Lists ----, these are the Flat Lists to which you should be importing the data from the csv files.

Later on, you will use a process to build the hierarchy Region > Country > Location

 

image.png

Einas
"Give a Man a Fish, and You Feed Him for a Day. Teach a Man To Fish, and You Feed Him for a Lifetime"

Dear community members
Consider posting your question as a new topic and not in the thread of another topic/question. This help other community members to easily find the answer they looking for and doesn't cause the original thread to be so cluttered that we can't find what we are looking for
sguptatalkingrain
Contributor

I am still getting error

 

sguptatalkingrain_0-1595640284879.png

Can anyone help on this error?

sguptatalkingrain
Contributor

got the solution. You only need to import the country name in country flat as column1.

huyenngo
Occasional Contributor

I encountered the same problem. The source file contains the "parent column". When I imported the file, it does not allow me to keep the parent column blank. 

 

huyenngo_0-1638227365780.png

what should I choose in the yellow highlighted part?

 

Thanks a ton! 

cuneydyasin
Contributor

Same issue here..

The list is under the "Flat Lists" but Anaplan doesn't let me proceed without assigning a parent.

What can I do now?

vsumanthreddy
New Contributor

press backspace in the box (instead of selecting from drop down) to make the parent option blank.. It will solve your problem
cuneydyasin
Contributor

Thanks a lot. Can't believe it could be that easy.. 🙂