Register

Level 2: Sprint 2: Error while running the 9 Import data from HUB for Importing Historic Volumes

Nethra
New Contributor

Level 2: Sprint 2: Error while running the 9 Import data from HUB for Importing Historic Volumes

Hi Team,

 

When i run the process 9 Import data from HUB in Supply Chain Model for importing the Historic Volumes, i get the below error message. I checked the Source model mapping, everything looks good. Not sure how to debug this error. Please help !!

9 REPLIES 9
CallumW
Certified Master Anaplanner

Re: Level 2: Sprint 2: Error while running the 9 Import data from HUB for Importing Historic Volumes

Hey @Nethra  - I am struggling to see the attachment (it won't open), can you reupload the message?

 

Best,

 

Callum

Nethra
New Contributor

Re: Level 2: Sprint 2: Error while running the 9 Import data from HUB for Importing Historic Volumes

Hi Callum,

 

Reuploading the error message.

Also uploading the snip of source model mappings of both Supply Chain & HUB models.

I think the error message is viewed only by downloading the files attached.

 

ChrisMullen
Community Boss

Re: Level 2: Sprint 2: Error while running the 9 Import data from HUB for Importing Historic Volumes

@Nethra 

If you are getting an error about the source not being found, you can remap the data source.  This is different than Source Models tab.

 

You can find it under Actions > Import Data Sources and click edit.  From here you can remap to your Data Hub model and saved view.

See attached.

 

Here is an article on Anapedia that has more information. 

https://help.anaplan.com/anapedia/Content/Import_and_Export/Map_Imports_to_New_Data/Import_Data_Sour...

 

-Chris 

Nethra
New Contributor

Re: Level 2: Sprint 2: Error while running the 9 Import data from HUB for Importing Historic Volumes

Please see the source model mappings for both the models.

Also the Import Data Sources for Historic Volumes.

CallumW
Certified Master Anaplanner

Re: Level 2: Sprint 2: Error while running the 9 Import data from HUB for Importing Historic Volumes

Thanks, @Nethra 

 

It looks as though everything is in order and probably easier just to try and remap the source as @ChrisMullen  suggested.

 

Other things to check could be that the saved view is still accessible and named in the right format and both models are available in the workspace (unarchived).

 

Best,

 

Callum

lps
Occasional Contributor

Re: Level 2: Sprint 2: Error while running the 9 Import data from HUB for Importing Historic Volumes

@ChrisMullen
I have the same error and tried remapping the data source i.e. Actions > Manage Import Data Sources. In doing this, I got a message stating that An import data source ("Level 2 Data Hub - .........) already exists for this object.

I tried re-importing 9 Import data from HUB for Importing Historic Volumes and still got the same error : Model object "'DAT03 Historic Volumes'.Export" could not be located.
Is there anywhere else I can check to trouble-shoot?
ChrisMullen
Community Boss

Re: Level 2: Sprint 2: Error while running the 9 Import data from HUB for Importing Historic Volumes

@lps   Under actions, You can edit the import Data Source.   Find the Data source for that import and you can remap it to the saved view in your data hub. 

lps
Occasional Contributor

Re: Level 2: Sprint 2: Error while running the 9 Import data from HUB for Importing Historic Volumes

ANS
Occasional Contributor

Re: Level 2: Sprint 2: Error while running the 9 Import data from HUB for Importing Historic Volumes

@ChrisMullen 

Remapping the source to correct model solved the issue. Thanks a lot for that.

 

However, I still wanted to understand the reason for remapping the source model.

 

At the end of Sprint 1 and before starting Sprint 2, we are asked to map the Source Model(Data Hub Model) from the Target Model(Supply Chain Model).This should take care of mapping from Target to Source.

 

ANS_0-1614677595460.png

My understanding from the above screenshot is "Level 2 Data Hub **Your Name**" is already mapped to "Level 2 Data Hub_Narender". That means system knows:

                           "Level 2 Data Hub **Your Name**" = "Level 2 Data Hub_Narender"

Then, why the process is getting failed when we run "Import Data from Hub" action?

 

ANS_2-1614678536927.png

Furthermore, I am able to edit other pre-existing actions like "2.3 Import Size", "9.2 Import Opening stock" etc., but not "9.1 Import Historic Volumes" from the Action tab. Which does have the same source model name "Level 2 Data Hub **Your Name**". Please check the screenshots below:

 

ANS_3-1614678998098.png

 

 

ANS_1-1614677974657.png

Thanks for you help.

Naren