Highlighted
Regular Contributor

Level 2 - Sprint 2

Historic volumes are imported to Supply Chain model - DAT03 Historic Volumes from Data Hub model - DAT03 Historic Volumes.Export (Saved View).

 

Data Hub model - DAT03 Historic Volumes.Export is a Saved View with filter criteria displaying Historic Volumes <> 0 so that data with zeros are not displayed and hence not exported.

 

When this was imported to the Supply Chain model - DAT03 Historic Volumes, zeros seemed to be imported....well, at least they were displayed.  I checked the Saved View file Data Hub model and the filter was applied.  

 

I am trying to figure out the reason for it.  Has anyone encountered this before?  Any feedback is much appreciated.

 

Supply Chain model:

Star_0-1589356212874.png

 

 

Data Hub model: Saved View

Star_0-1589356359725.png

 

 

6 REPLIES 6
Certified Master Anaplanner

Re: Level 2 - Sprint 2

Can you ensure the export-view is used as a base. This can be easily done via the actions - imports:

 

MaartenGijbels_0-1589358998522.png

 

Highlighted
Frequent Contributor

Re: Level 2 - Sprint 2

Hi @Star ,

 

I dont think Zero are getting exported. IN the target modules since you have all the members, they are just being displayed without any value which is zero .

 

TO test this, you can add a negative value in data hub and make your view using the condition Historic Volumes > 0, In this case if the negative value isn't exported, it will prove that zeros are also not exported from your view.

 

Let me know if it helps.

 

Thanks,

Yash

Highlighted
Regular Contributor

Re: Level 2 - Sprint 2

@MaartenGijbels  @Yash1 


Zeros are not exported. I tested by manually doing a Data Export (Include and Omit Empty Rows) and the Exported file are the same.
@Yash1, I also tried your suggestion of using a negative number and changing the condition to Historic Volumes >0. The negatives were not exported. Again prove that zeros were not exported.

The source model is pointing to the Saved View whereby zeros are suppressed.

Star_0-1589362450740.png

I then reset Target Dat03 Historic Volumes.Volumes to NO DATA and then to Number again. 

When it was set to NO DATA, the view was blank (not zeros). After switching to Number again, the blanks changed to zeros.

 

So, the question is how to set these to blanks before even importing.

 

 

Highlighted
Certified Master Anaplanner

Re: Level 2 - Sprint 2

Hi @Star ,

 

There is a difference between exporting a view and using that view as the basis for an import. They are 2 different actions.

 

The export view might contain those filters why the import view does not.

 

All the best,

Highlighted
Valued Contributor

Re: Level 2 - Sprint 2

Hi @Star 

@Yash1 is correct, those 0 were not imported. they are the default value for the line item in the target module.
If you want the cells that contain zeros to be blank then you can adjust that in the Format dialogue. (see screenshot)
It is customary to use the Hyphen as the default values for zeros but of course, all options are valid.
Also, the way to achieve this is not to set the "blanks" in the source file and expect them to be copied to the target module. You have to set the zero format to blank in the target module. This is just a display issue and it doesn't affect the actual value of the line items

Hope that helps

 
 
 

image.png

 

 

Einas
Highlighted
Regular Contributor

Re: Level 2 - Sprint 2

@einas.ibrahim
Thanks so much for your explanation and screenshot. Very helpful indeed.
@Yash1 's suggesting was really good in proving that zero was not exported from target.

The reason why I was asking in the first place was because I was looking at it from the perspective of model size. I thought zeros would take up space and was wondering why there were zeros in the target module when the source did not have.

Thanks, again 🙂