Module to module import issue

Contributor

Module to module import issue

Hi 

 

We have configured some imports within our modules where 1 line item is imported to another line item from one list member to the next. The List we have used here is Target Setting Stage. So a target being set in one stage is copied to the next stage using these imports as a Previous Stage Target.

Now, the issue we are facing is that these imports are not working when a user tries to run it from a dashboard. Whereas, the imports are working fine for Workspace Admins. We have checked the user access and roles and the user has access to all the lists and modules being used in the imports. 

Please let me know anything we are missing here. In case this is a known issue, what could be the workaround for this?

 

Regards

Saurabh

 

Message 1 of 14
13 REPLIES 13
Frequent Contributor

Re: Module to module import issue

Hi Saurabh,

 

Check all the below items,

 

1. Action Access

2. List Access

3. Source Module Access

4. Target Module Access

 

~Vignesh

Message 2 of 14
Contributor

Re: Module to module import issue

Hi @VIGNESH.M 

This issue was tested by a user with Full Access which covers the access to all actions, lists and modules. Also, we made sure the user was having complete access to the lists with Selective Access enabled.

Saurabh

Message 3 of 14
Frequent Contributor

Re: Module to module import issue

@saurabh.raheja ,

 

Can you share the screenshot of the error?

 

It's working for Full access role, but not working for end users?

 

~Vignesh

Message 4 of 14
Contributor

Re: Module to module import issue

There is no error, process is shown as successful after running. But, the numbers are not updating after running.

No it's not working for Full Access as well. Only working for 'Workspace Admin'.

Message 5 of 14
Frequent Contributor

Re: Module to module import issue

@saurabh.raheja ,

 

Check the role of the person whom it's working with WSA access.

I assume the person has Full access with WSA.

 

You are not getting any error and its working for WSA full access, so it must be an Access issue.

 

Check the selective access.

 

~Vignesh

Message 6 of 14
Expert

Re: Module to module import issue

@saurabh.raheja 

Can I just add, and I know I don't know all of the details, but if you can, it would be better not to have users running the copies at all. 

 

Is there a reason why you cannot model the movement from stage 1 List item 1 to Stage 2, List item 2 through formulas?

 

David

Message 7 of 14
Contributor

Re: Module to module import issue

Hi @DavidSmith 

The reason why the formulas are not used is that Stage 2 Line Item 1 (same line item copied to Stage 2 Line Item 2 from Stage) is dependent upon Stage 2 Line Item 2 for calculation. So, if a formula is used to link the 2, it will give a Circular Reference. The way to counter this is to add new line items for each stage which we had initially done, but that adds to a lot of maintenance effort, due to which we moved to the Imports/Copy approach. 

Is there any known workaround to fix the imports for users?

 

Saurabh

Message 8 of 14
Highlighted
Expert

Re: Module to module import issue

As outlined above by @VIGNESH.M  it is almost 100% likely to be down to access, as there are no known issues with end users running internal imports 

David

Message 9 of 14
Contributor

Re: Module to module import issue

I will re-check this point, but I'm quite sure that at the time of testing, the user had Full Access with complete access to the lists with Selective Access. The same thing I tested with another team member's credentials as well after giving full access to the model without WSA Access, but the import was not working correctly.

Message 10 of 14