Anaplan Connect Error - Process

Highlighted
Community Boss

Anaplan Connect Error - Process

Hi team,

 

I'm trying to use Anaplan connect to run a Import process but my script is incorrect. I attempted to modify my working import script per the instructions in the Anaplan Connect guide (pg 27) but it is not working

 

Below is my script and error, any help would be appreciated!

 

SS2.PNGSS3.PNG

4 REPLIES 4
Highlighted
Master Anaplanner/Community Boss

Re: Anaplan Connect Error - Process

Hi Mark,

 

I can see you have separated Process & Get as separate rows, can you keep those with Set Operation command and try to run the process.

Set Operation = -File " " -Put " " -File " " -Put " " -Process " " -execute -get " "

 

~Vignesh M

Highlighted
Community Boss

Re: Anaplan Connect Error - Process

Hi @VIGNESH.M ,

 

Thanks for your help, unfortunately it didn't quite work. I did adjust the script a little but I have definitely got something incorrect. Could you take another look for me?

 

FYI - The Process is 2 Import actions which use 1 file each

 

Thanks!

 

SS4.PNGSS5.PNG

Highlighted
Master Anaplanner/Community Boss

Re: Anaplan Connect Error - Process

Hi Mark,

 

See the screenshot, there is a mismatch in the command. Change the Import to Process.001.png

 

Here is the script I tried, this is working fine for me.

@echo off
rem This example runs a Process that contains multiple Export actions
set AnaplanUser=vignesh.com:password
set WorkspaceId="8a81b09b599f39sds159be1157d87218"
set ModelId="59362461744sdsd89A33D634942F3E0F"
set Operation= -file "Account List.CSV" -put "C:\anaplan-connect\Account List.CSV" -file "Country.CSV" -put "C:\anaplan-connect\Country.CSV" -process "Upload Account" -execute
rem *** End of settings -Do not edit below this line ***
setlocal enableextensions enabledelayedexpansion || exit /b 1
cd %~dp0
if not %AnaplanUser% == "" set Credentials=-user %AnaplanUser%
set Command=.\AnaplanClient.bat %Credentials% -workspace %WorkspaceId% -model %ModelId% %Operation%
@echo %Command%
cmd /c %Command%
pause

 

Regards,

Vignesh M

Highlighted
Community Boss

Re: Anaplan Connect Error - Process

Thanks Vignesh! - I understand how the scripting is working now