Anaplan Connect Error

aishabhy05
Contributor

Anaplan Connect Error

Hi All,

 

I have an issue while uploading the file via Anaplan connect. Following is a snippet of the error.
>
> _2021-02-26 17:35:07 INFO  [c.a.client.Service  :83   ] 1532 |--
> Initializing Service..._
> _2021-02-26 17:35:07 INFO  [a.BasicAuthenticator:26   ] 1532 |--
> Authenticating via Basic..._
> _2021-02-26 17:35:11 INFO  [c.a.c.l.LogUtils    :44   ] 1532 |--   = =
> = = = = = = = = = = = = = = = = = = = = = = = = = = = =_
> _2021-02-26 17:35:11 INFO  [c.a.c.TaskFactory   :118  ] 1532 |--
> Running Process: Import From Datalake SP SG FOM (id=118000000058)_
> _2021-02-26 17:35:14 INFO  [c.a.client.Task     :207  ] 1532 |--   Run
> status: Failed._
> _2021-02-26 17:35:14 INFO  [c.a.c.l.LogUtils    :56   ] 1532 |--
> -----------------------------------------_
> _2021-02-26 17:35:14 INFO  [c.a.client.Task     :230  ] 1532 |--   !!!
> The operation failed !!!  =(_
> _2021-02-26 17:35:14 INFO  [c.a.c.l.LogUtils    :60   ] 1532 |--   - -
> - - - - - - - - - - - - - - - - - - -_
> _2021-02-26 17:35:14 INFO  [c.a.client.Task     :3880 ] 1532 |--   The
> uploaded file is no longer available; please upload the file again_
> _2021-02-26 17:35:14 INFO  [c.a.client.Task     :3880 ] 1532 |--   The
> uploaded file is no longer available; please upload the file again_
> _2021-02-26 17:35:14 INFO  [c.a.client.Task     :3880 ] 1532 |--
> errorMessage - The uploaded file is no longer available; please upload
> the file again_
> _2021-02-26 17:35:15 DEBUG [c.a.client.Program  :1726 ] 1552 |--

 

 

However, the file is available in the storage location. Any suggestions? Please note that source label names are matching. While I was configuring the import action, I made as Keep private. Will this impact? If yes, any possible ways i can change back to admin? 

aishabhy05_0-1614348667162.png

 

 

Thanks,

Aish

1 ACCEPTED SOLUTION

Accepted Solutions
JaredDolich
Moderator

Re: Anaplan Connect Error

@aishabhy05 

It appears that the file is no longer there. If you uploaded it in the last 48 hours then let's try another approach. Let's take a look at your Anaplan Connect Script. Let's make sure you're import file name is the same as the import data source (the name of the file you used to create the import action).

Now, I use the command window in Windows but your Script should look something like this:

There are 3 really import switches that have to be set (I highlighted them in red for you)

  • File | This must be the name of the file in ANAPLAN that you used to create the action in the first place. Check Import Data Source to validate.
  • Put | This is the location of the file you want to import. Ideally, it will have the same name and I believe this is a best practice.
  • Import | this is the name of the action that you created using the File above.

See if that helps!

@echo on
rem ---------------------
rem Instantiate Variables
rem ---------------------
set AnaplanUser="Your ID"
set WorkspaceId="Your Workspace"
set ModelId="Your Model"

rem ---------------------------------------------------
rem Import File to Anaplan
rem ---------------------------------------------------
set Operation=-service "https://api.anaplan.com" -auth "https://auth.anaplan.com" -file "SKU Trans.csv" -put "C:\Temp\Citi Trends\SKU Trans.csv" -import "002_MD_HISTORY_ KEYS_LIST" -execute -output "C:\Users\jdoli\AnaplanConnect\Errors.txt"

 

rem *** End of settings - Do not edit below this line ***
setlocal enableextensions enabledelayedexpansion || exit /b 1
cd %~dp0
if not %AnaplanUser% == "" set Credentials=-user %AnaplanUser%
set Command=.\AnaplanClient.bat %Credentials% -workspace %WorkspaceId% -model %ModelId% %Operation%
@echo %Command%
cmd /c %Command%
pause


Jared Dolich

View solution in original post

6 REPLIES 6
Misbah
Moderator

Re: Anaplan Connect Error

@aishabhy05 

 

If you wish to load the source file again then go to Actions->Import Data Source->New Source ->Upload New File (make sure that the name of the file matches with the file that was loaded earlier)

 

 

I would have said since it is past 48 hours you need to upload the file again. But this made me think otherwise. @ben_speight  what is the correct behavior here?

Misbah_0-1614340448831.png

https://help.anaplan.com/ebc01b56-7b57-4e36-93de-acfdb75a8441-Overview-of-Private-and-Default-Files#...

Misbah

 

 

ben_speight
Super Contributor

Re: Anaplan Connect Error

Normally you upload the file(s) and then run the process in a single command. Any file uploaded via the API is a private copy and will be removed after 48 hours.

aishabhy05
Contributor

Re: Anaplan Connect Error

@ben_speight  , @Misbah I have to reupload the source file with "Set as Default" to everyone to avoid the error? Is my understanding correct? 

JaredDolich
Moderator

Re: Anaplan Connect Error

@aishabhy05 You got it!


Jared Dolich
aishabhy05
Contributor

Re: Anaplan Connect Error

@JaredDolich  But still the same error. Any inputs please? 

aishabhy05_0-1614442738174.png

 

JaredDolich
Moderator

Re: Anaplan Connect Error

@aishabhy05 

It appears that the file is no longer there. If you uploaded it in the last 48 hours then let's try another approach. Let's take a look at your Anaplan Connect Script. Let's make sure you're import file name is the same as the import data source (the name of the file you used to create the import action).

Now, I use the command window in Windows but your Script should look something like this:

There are 3 really import switches that have to be set (I highlighted them in red for you)

  • File | This must be the name of the file in ANAPLAN that you used to create the action in the first place. Check Import Data Source to validate.
  • Put | This is the location of the file you want to import. Ideally, it will have the same name and I believe this is a best practice.
  • Import | this is the name of the action that you created using the File above.

See if that helps!

@echo on
rem ---------------------
rem Instantiate Variables
rem ---------------------
set AnaplanUser="Your ID"
set WorkspaceId="Your Workspace"
set ModelId="Your Model"

rem ---------------------------------------------------
rem Import File to Anaplan
rem ---------------------------------------------------
set Operation=-service "https://api.anaplan.com" -auth "https://auth.anaplan.com" -file "SKU Trans.csv" -put "C:\Temp\Citi Trends\SKU Trans.csv" -import "002_MD_HISTORY_ KEYS_LIST" -execute -output "C:\Users\jdoli\AnaplanConnect\Errors.txt"

 

rem *** End of settings - Do not edit below this line ***
setlocal enableextensions enabledelayedexpansion || exit /b 1
cd %~dp0
if not %AnaplanUser% == "" set Credentials=-user %AnaplanUser%
set Command=.\AnaplanClient.bat %Credentials% -workspace %WorkspaceId% -model %ModelId% %Operation%
@echo %Command%
cmd /c %Command%
pause


Jared Dolich

View solution in original post