Anaplan connect: error in upload

Highlighted
Occasional Contributor

Anaplan connect: error in upload

Hi, 

 

Currently we are working on automating the process uploads with Anaplan connect. 

An error occurs for data transfer between 2 models in Anaplan. 

 

If the process is ran via the scripts, I get the following error: 

Import into module failed: The column headers in the file you are attempting to import do not match the import definition. The column headers in the file you are attempting to import do not match the import definition.

 

If I do the process manually (process in Anaplan), then everything goes well.

What can be the reason of this issue?

 

Thank you in advance. 

Kind regards,

Catheline

8 REPLIES 8
Highlighted
Certified Master Anaplanner

Re: Anaplan connect: error in upload

Hi @Catheline ,

 

Anaplan connect requires a user, does that user have all required access-rights?

 

Maybe try to run the script with your personal username and password to verify if it would work the same.

 

It's a bit of a guess, but it's the error you get when the sources are different. So it would be the most obvious cause..

 

All the best,

Highlighted
Occasional Contributor

Re: Anaplan connect: error in upload

Hi @MaartenGijbels  

 

It seems indeed linked to the access rights of the upload user. 

But at this moment this user has "Full access" and it still doesn't work.  

Any idea how this can be solved?

 

Kind regards,

Catheline

Highlighted
Certified Master Anaplanner

Re: Anaplan connect: error in upload

Hi Catheline,

 

Can you try with him as an "Admin"? That should ensure all security requirements are met...

 

If it's something else we'll need more information. Like the scripts, detailed errors, ...

 

All the best,

Highlighted
Occasional Contributor

Re: Anaplan connect: error in upload

Thank you. 

It works like this.

Highlighted
Certified Master Anaplanner

Re: Anaplan connect: error in upload

Hi @Catheline ,

 

Great to hear it works!

 

This means:

- the process works fine;

- the anaplan connect batch file is set up correctly

 

=> the issue is in security.

 

When you have more time:

It would be worth while investigating if the FULL ACCESS has all the required read, write, access settings, ... Do not forget about any selective access that might have been set.

 

All the best,

Maarten.

 

Highlighted
Frequent Contributor

Re: Anaplan connect: error in upload

Hi @Catheline ,

 

Are you using the same file/module/view which you used at the time of creation of the action.

The Anaplan command line just runs the process/Action , the only possibility of an error is in case you are using a different source (or the source module/view is changed). Do you want to recheck your source and try again.

 

Thanks,

Yash

Highlighted
Frequent Contributor

Re: Anaplan connect: error in upload

Hi @Catheline,

 

Please make sure that Column Header & Data Row in the File should match with the Header and Data Row in the import definition while creating action because Created action is going be use in the Script and same file should be use in the script while running it.

 

Column Header in the file 

 

naushad786_1-1589355440065.png

 

 

 

 

Header Row In the Import Definition

naushad786_0-1589355394866.png

 

 

Thanks,

Naushad

 

Highlighted
Contributor

Re: Anaplan connect: error in upload

Hi @Catheline

Can you post a screenshot of the module of both the model and scripts file if possible , so we can see the mapping logic there?

Also, if you could post the "Details" section of the error message

 

regards,

Parmod