Collect() function results zero values - why?

Dominika_Dudzinska
Occasional Contributor

Collect() function results zero values - why?

Hello, 

I used collect() function to take data from the source module. 

I created LISS from the source module and then used as dimension in the target module.

The dimension are the same in the both module, unfortunately I see zero values after using collect().

Can you help me understand why?

 

Thank you. 

Best regards, 
Dominika

4 REPLIES 4
anand.shekhawat
Super Contributor

Re: Collect() function results zero values - why?

@Dominika_Dudzinska 

 

Is it possible to please share some snips of your build

 

~Anand

KirillKuznetsov
Certified Master Anaplanner

Re: Collect() function results zero values - why?

Hi 

Most probably you are missing some dimensions from your source in your target model.

The target must have the source dimensions OR all missing dimensions have to have Total list element and summary of the line item in the source have to be turned on.

Bruce986
New Contributor

Re: Collect() function results zero values - why?

Likewise, we may want to collect() some things from matched paths when there The other aggregation functions can produce similar results when run on 0 rows. a grouping key is NOT the same as having a grouping key of null values).

 

ePayitonline

Dominika_Dudzinska
Occasional Contributor

Re: Collect() function results zero values - why?

Hello, 

OK, I already understood where the problem is. 

I had LISS in the source model and corresponding line items in the target model to map to. 

The mapping is not possible, because the dimension is different, so it was giving 0. 

 

Thank you all for your help.  

Best regards, 
Dominika