Compare/Sync Error attempting ALM from Dev workspace to Prod workspace

Highlighted
Contributor

Compare/Sync Error attempting ALM from Dev workspace to Prod workspace

Firstly, here is the error message.Does anyone know this? What could be the reason?

'Model Comparison failed

Sorry, but we couldn't find the revision data files required for this comparison. 

Please contact Anaplan Support.'

 

We have 3-workspace(Dev, QA, Prod) and did operations bellow.

import: Development workspace -> Production workspace **successed**

ALM:    Development workspace -> Production workspace **successed**

import: Development workspace -> Production workspace **successed**

ALM:    Development workspace -> Production workspace **failed**

 

 

 

17 REPLIES 17
Highlighted
Master Anaplanner/Community Boss

Re: Compare/Sync Error attempting ALM from Dev workspace to Prod workspace

@litterbarbie 

 

What is second Importing doing?

 

Have you created fresh Revision Tag in Dev Model before you actually start pulling the changes from Dev to Prod?

Highlighted
Contributor

Re: Compare/Sync Error attempting ALM from Dev workspace to Prod workspace

hi Misbah,

 

Thks for replying.

 

>What is second Importing doing?

Second Importing is the first release to Production WS).

(First Importing is release to QA WS)

 

>Have you created fresh Revision Tag in Dev Model before you actually start pulling the changes from Dev to Prod?

Fresh Revision Tag? yes, I create a new (empty) Revision Tag before ALM.

btw, I have plenty Revision Tags before the Fresh Revision Tag, and the errors comes no matter which Revision Tag I choose.

Highlighted
Contributor

Re: Compare/Sync Error attempting ALM from Dev workspace to Prod workspace

Hi @litterbarbie 

 

Please check the below items:

1. Is there a revision tag created before you attempted the sync?

2. If "yes" to 1, then check whether you have sufficient space in the Prod Workspace for the sync to happen properly.

 

If yes to 2, I suggest you raise it to Anaplan support.

 

Thanks.

Highlighted
Contributor

Re: Compare/Sync Error attempting ALM from Dev workspace to Prod workspace

hi @Nagaraju 

 

OK, It's 2..

Thank you very much!

I'll try to contact anaplan support.

Highlighted
Master Anaplanner/Community Boss

Re: Compare/Sync Error attempting ALM from Dev workspace to Prod workspace

@litterbarbie 

 

That is why it has been penned down as a rule. You should always create one RT a day and test it against a dummy/Shell  model instead of waiting to accumulate all the RTs

Misbah_0-1595317710707.png

 

Highlighted
Contributor

Re: Compare/Sync Error attempting ALM from Dev workspace to Prod workspace

Thank you! Very good suggestion!
Highlighted
Contributor

Re: Compare/Sync Error attempting ALM from Dev workspace to Prod workspace

@litterbarbie 

If you do not have sufficient workspace size, try to make up enough space, either by decreasing model size or increasing workspace size. Then only, you will be successfully able to sync.

 

Thanks 

Highlighted
Contributor

Re: Compare/Sync Error attempting ALM from Dev workspace to Prod workspace

But the Production workspace is only 2% full..
Highlighted
Community Boss

Re: Compare/Sync Error attempting ALM from Dev workspace to Prod workspace

This is strange,

 

If i understand correctly,

 

1. Dev >> Create revision tag #XX

2. QA >> Compare / Sync from Dev.#XX >> Successful

3. PROD >> Compare / Sync from Dev.#XX >> You get the error

 

Fee questions,

QA & PROD were created from the DEV?

Is this the first time you are syncing PROD, or you have synced PROD previously successfuly?

 

Thanks

Arun