Highlighted
Occasional Contributor

Data fields are offset when retrieving data in Chunks via API

I'm retrieving a large export via the API and because of the size of the file, Anaplan breaks up the export into multiple chunks. The issue is the column structure in the first and last record of each chunk isn't consistent. For example, in the attached image, the first chunk ended on the first row mid-way through the Version field and continued in the first row of the following chunk. Since a chunk can cut off at any point in the row, I don't see any practical way of piecing the data back together. Is there any workaround for this?

 

AW25_0-1581630440085.png

 

4 REPLIES 4
Highlighted
Master Anaplanner/Community Boss

Re: Data fields are offset when retrieving data in Chunks via API

@AW25 

I've honestly never seen that happen before.

Two suggestions:

First it might help is to set the chunk size.

You can read this post, scroll down to @Misbah solution. See if that helps.

This assumes you're using Anaplan Connect though.

 

The other, which is really unlikely but worth mentioning is to make sure you don't have any control characters that might be interpreted as a delimiter from your source module. Sometimes people use special characters, like the emoji set. These cause all kinds of problems.

 

Can you give us more specifics about which export method you're using?

Honestly, I've used almost all of them and never had this problem. You might also consider posing this to support@anaplan.com.

 

 


Jared Dolich
Occasional Contributor

Re: Data fields are offset when retrieving data in Chunks via API

Hi @Jared Dolich,

 

Thanks for the reply. I'm using the method outlined here in the API v2 documentation. I've attempted to get the data via Alteryx and Postman and had the same issue with both.

 

There aren't any special characters in this dataset. This break actually happens in the middle of number strings as well. The documentation says that the chunk size for Exports is set to 10MB but I couldn't find any information on changing that.

Highlighted
Master Anaplanner/Community Boss

Re: Data fields are offset when retrieving data in Chunks via API

@AW25 

 

This is expected behaviour . What i normally do is 

 

I open a file(this is my final output file) in write mode and keep it open and [Loop]then make a API request for chunk 0 , read content  and write to the open file[LOOP] . I loop this until i reach the end of chunk count . Then i close and save the file . This gives me 1 complete file without breakage 

 

I dont know how to achieve above in either Alteryx or Postman . Hoping someone posts more solutions here 

 

Highlighted
Master Anaplanner/Community Boss

Re: Data fields are offset when retrieving data in Chunks via API

@AW25 

 

Try this 

 

Change your URL from 

 

https://api.anaplan.com/2/0/workspaces/workspaceid/models/modelid/files/fileid/chunks/chunkid

 

to

 

https://api.anaplan.com/2/0/workspaces/workspaceid/models/modelid/files/fileid/

 

 

Change your postman settings to get max response size in MB to 0(infinite)

 

{02D1DBB3-A602-4EC0-A506-A4FFE1D9E36D}.png.jpg

 

 

PS: Postman has issues with large file so you might have to try few times . Alternatively try same in Alteryx 

 

hope this helps