During Export from Anaplan through API we are getting special Charactors 

timmapuramreddy
New Contributor

During Export from Anaplan through API we are getting special Charactors 

When we run a process and export a file from Anaplan through API we are getting special characters () in the csv file header like below 

timmapuramreddy_0-1619098516919.png

but when we export directly from Anaplan it comes blank without any special characters which is right and expected

timmapuramreddy_1-1619098603485.png

Did any one phased this kind of problem, can you please suggest

 

Thanks In Advance

 

Mohan

 

3 REPLIES 3
alexpavel
Certified Master Anaplanner

Re: During Export from Anaplan through API we are getting special Charactors 

@timmapuramreddy I did not encounter this issue...What option of the file did you choose in the export action? CSV? TXT?

When you open the file exported from Anaplan using REST API in a notepad++ what Encoding do you see?

what do you see by opening the file exported from Anaplan?

 

Did you run the export REST API using in body the {"localeName":"en_US"}

 

Hope it helps

Alex

 

ben_speight
Super Contributor

Re: During Export from Anaplan through API we are getting special Charactors 

If the format is 'comma separated values for Excel (.csv)' then the file starts with a byte order mark (BOM) sequence to ensure that the reading application uses the UTF-8 encoding. It's possible that this sequence has been further re-encoded by other tools (if not you might see the text "" in the first cell). Check that what you used to retrieve the file is not trying to convert the content to a character sequence, or use the vanilla CSV format - but make sure anything that reads it is expecting UTF-8.

kevin.cho
Certified Master Anaplanner

Re: During Export from Anaplan through API we are getting special Charactors 

One thing that you may want to check is the encoding of the file. Can you enforce UTF-8 encoding in whatever tool/script you are using to call the Anaplan API?