Filter issues

Highlighted
New Contributor

Filter issues

Hi Team,

I have observed one issue popped up with filters in a dashboard.

i am able to apply and view the data in Dev 

anilp_1-1604313485297.png

 

However, when i move the chagne to qa , the filters are disappearing and the data is not displayed.

anilp_0-1604313443946.png

we have items in L4 level too. Could any one suggest what is the exact issue?

Thanks in advance.

 

5 REPLIES 5
Highlighted
Certified Master Anaplanner

Re: Filter issues

Hi Anilp,

 

It looks to me to be a data or access issue.

It sounds like you do not have any item in your L4 Sub-Market Channel list (or not access to them) therefore the fitlers aren't shown. Add a least one item in your list and you should be able to view your filter.

 

Let me know how it goes.

 

Regards

Highlighted
New Contributor

Re: Filter issues

Thank you for the response. i have workspace admin to the model and there is no roles defined in it. in addition to that, we have data in the L4 list level too.  

 

Any further suggestions?

Highlighted
Certified Master Anaplanner

Re: Filter issues

No selective access enabled on that list?

Also, do you have any filter applied to the L4 list which would prevent the module from displaying any data?

 

 

Highlighted
Super Contributor

Re: Filter issues

Hi @anilp 

 

It may be because of the filter condition as of now you have added two filter and  Show items that match having  ALL of the following so it acting as AND condition.

Please check your filter condition & your time filter module whether it's marked as True or not

Example:

Screenshot_486.png

Screenshot_487.png

 

 

2) when both Condition met then it will show the required time. 

Screenshot_488.png

Screenshot_489.png

 

Hope this helps!

Thanks

Akhtar

 

 

 
Highlighted
Master Anaplanner/Community Boss

Re: Filter issues

@anilp 

 

This won't help with your access issue, but you should really think about combining those filters into one line item for performance reasons.  Why?  The way Anaplan works is it will retrieve the data for the first filter and then it will re-read the data for the 2nd filter.

 

Rob