Format Date in the New UX is different from the model one

chaualexan
Occasional Contributor

Format Date in the New UX is different from the model one

Hi everyone,

 

I am a french builder, building a model for a french customer, and on the model (or old UX), the date format is dd/mm/yyyy.

 

On the New UX the format seems to be the same (dd/mm/yyyy), except that when entering the calendar it's in english, where it was in french in the old UX. So far that's not a real problem.

 

However, when entering manually a date, without passing by the calendar, it is entered as the american date format mm/dd/yyyy, thus entering the wrong date, 21/12/2021 becoming 2001-02-01 for some reason (guess it's a bug since 21 is supposed to be a month so <= 12).

Capture d’écran 2020-12-21 à 19.08.29.png

Here's an example, you can see below the date 21/12/2020, (21 st of December 2020)  selected via the calendar in the good format, but when I manually enter 10/12/2020 (10 th of December 2020), I get 12 th of October.

 

Is it a known bug waiting for an update or is there something to do about it ?

 

Thanks to anyone helping ! 

 

9 REPLIES 9
rob_marshall
Moderator

Re: Format Date in the New UX is different from the model one

@chaualexan 

 

I believe those formats are based on the regional settings of the computer, not Anaplan.  I would take a look to see what the regional settings are for your machine.

 

Rob

chaualexan
Occasional Contributor

Re: Format Date in the New UX is different from the model one

Hi @rob_marshall,

 

Thank you for your response, I think it does depend from the regional settings from my computer, or my browser, for the model, where it is well in french on the module. However, it's in the new UX where the format change while my settings haven't.

 

Here's a screenshot of my regional setting for my machine, which is France and hasn't changed since the beginning :  

 

Capture d’écran 2020-12-21 à 19.59.45.png

rob_marshall
Moderator

Re: Format Date in the New UX is different from the model one

@chaualexan 

 

which browser are you using?

chaualexan
Occasional Contributor

Re: Format Date in the New UX is different from the model one

@rob_marshall 

 

I am using Google Chrome

rob_marshall
Moderator

Re: Format Date in the New UX is different from the model one

@chaualexan 

 

Interesting...So, it works correctly in the module but not in the NUX?

 

Rob

chaualexan
Occasional Contributor

Re: Format Date in the New UX is different from the model one

@rob_marshall 

 

Yes that's it.

 

They also reported an error with the form action, when they select a date when the date is blank, they get the date minus one day, but not when a date is already there. This is really strange and I don't know why it happens. I recorded this in the video attached.

 

Thank you for your time Rob ! I think I will contact Anaplan support for these problems and will post on this thread if there's a solution.

rob_marshall
Moderator

Re: Format Date in the New UX is different from the model one

@chaualexan 

 

Ok, that is really strange.  Can you check account timezone (top right corner, click on My Account).

 

2020-12-22_08-17-21.png

 

Rob 

chaualexan
Occasional Contributor

Re: Format Date in the New UX is different from the model one

@rob_marshall 

 

Account Anaplan.png

rob_marshall
Moderator

Re: Format Date in the New UX is different from the model one

@chaualexan 

 

Ok, I am at a loss.