Having trouble mapping a flat file

neg177
Super Contributor

Having trouble mapping a flat file

Hi,

 

I'm having trouble mapping this flat file into my Module. It will not let me manually map my data when I choose that option. Please advise. Pics are attached. 

 

Thank you 

4 ACCEPTED SOLUTIONS

Accepted Solutions
ashish.banka
Super Contributor

@neg177 It seems that the line items which are not mapped does not have any data in the source file, hence Anaplan engine is not allowing to map them manually. If you have values in those cells, it would either automatically map or allows manual mapping.

 

Hope this helps.

AB

View solution in original post

sandeep_bk
Regular Contributor

@ashish.banka  I wonder, not having the data in the source would impact the line item mapping?

 

@neg177, can you make sure the line items you are trying to map are not formula-driven? line-items that are mappable(input fields) are eventually showup in blue texts in the target section.

 

Thanks,

Sandeep

 

 

View solution in original post

ashish.banka
Super Contributor

@sandeep_bkyou are correct. However I assumed that @neg177 would be trying to load data into input line item rather than formula line item.

 

I think it would be a great feature for Anaplan platform to disable mapping for those line item which does not have any data in the source file to avoid mistake.

 

AB

View solution in original post

ChrisAHeathcote
Community Boss

@neg177 

From your screenshot it would appear that all items that can be mapped in the target are allocated to a line item in the source. Unmapped items in the target will appear as blue in the box at the bottom right of the screen.

 

Ensure that all line items in the target which you want to import data into do not contain any formulas. Only empty line items will appear as mappable and will be marked in blue.

 

Good luck,

 

Chris 

Chris
HeathcoteAndHerran.com

View solution in original post

5 REPLIES 5
ashish.banka
Super Contributor

@neg177 It seems that the line items which are not mapped does not have any data in the source file, hence Anaplan engine is not allowing to map them manually. If you have values in those cells, it would either automatically map or allows manual mapping.

 

Hope this helps.

AB

sandeep_bk
Regular Contributor

@ashish.banka  I wonder, not having the data in the source would impact the line item mapping?

 

@neg177, can you make sure the line items you are trying to map are not formula-driven? line-items that are mappable(input fields) are eventually showup in blue texts in the target section.

 

Thanks,

Sandeep

 

 

ashish.banka
Super Contributor

@sandeep_bkyou are correct. However I assumed that @neg177 would be trying to load data into input line item rather than formula line item.

 

I think it would be a great feature for Anaplan platform to disable mapping for those line item which does not have any data in the source file to avoid mistake.

 

AB

ChrisAHeathcote
Community Boss

@neg177 

From your screenshot it would appear that all items that can be mapped in the target are allocated to a line item in the source. Unmapped items in the target will appear as blue in the box at the bottom right of the screen.

 

Ensure that all line items in the target which you want to import data into do not contain any formulas. Only empty line items will appear as mappable and will be marked in blue.

 

Good luck,

 

Chris 

Chris
HeathcoteAndHerran.com
neg177
Super Contributor

I removed the formulas like you said and the data mapped beautifully.

 

Thank you