How to avoid garbled characters when importing

hyudolee
Occasional Contributor

How to avoid garbled characters when importing

Hi, I want to import csv file which has Shift-JIS encoding which is Unique code in Japan.

I have a problem the text has "(株)", "No.". 

<Data source>

No.

<Anaplan>

��

 

I think this text is windows's environment-dependent character.

So I changed the import setting from Shift-JIS to windows-31, and I could solve it.

 

Does anybody faced this problem?

I'm afraid that I will face another problem because of this change.

 

Of course, if I use UTF-8, I can solve it.

But the customer's excel was old, so I have to chose this encoding.

1 REPLY 1
Valtierra112
Not applicable


@Target Card Balance Now wrote:

Hi, I want to import csv file which has Shift-JIS encoding which is Unique code in Japan.

I have a problem the text has "(株)", "No.". 

<Data source>

No.

<Anaplan>

��

 

I think this text is windows's environment-dependent character.

So I changed the import setting from Shift-JIS to windows-31, and I could solve it.

 

Does anybody faced this problem?

I'm afraid that I will face another problem because of this change.

 

Of course, if I use UTF-8, I can solve it.

But the customer's excel was old, so I have to chose this encoding.


It is also worth knowing about BOM - Byte Order Markers. Notepad under Windows, and EditPlus will give different output files when saving "hello, world" as UTF-8. The Notepad version will be three bytes longer, and yet both are technically correct (though redundant for UTF-8).

It can cause problems when importing UTF-8 data into applications that do not take the BOM into account, when non-technical end-users use the only tool they have available for generating or converting UTF-8 data on Windows.