Register

How to keep Filters active even after changing dimensions

SudhirY
Contributor

How to keep Filters active even after changing dimensions

Hi All,

 

Hope everyone is doing safe during this pandemic. 

 

I'm trying to apply filters on time dimension on a standalone basis, but unable to do unless I bring in other dimension to columns. When I change the view I lose the time filter based on a line item in the same module - 'Current Year?'. Any reasons why Filters become inactive with change in dimensions? 

 

How do we go about keeping filters active even after changing dimensions? hope there is a quick and easy way to deal with this than a long workaround.

 

regards

Sudhir

6 REPLIES 6
ChrisHeathcote
Community Boss

Re: How to keep Filters active even after changing dimensions

@SudhirY 

Use a filter module which only contains time period as a dimension.

I suspect you are creating the time filter in the same module as the data to be filtered. This is not best practice as you will need to recreate the filter each time it is required.

By creating a single filter source only containing time it can be used in all modules that require it. 

When applying this filter to any other module the view will remain filtered despite changes in the dimension.

 

Chris Heathcote
Bedford Consulting

Gold Partner and Regional Partner of the Year 2021, EMEA
SudhirY
Contributor

Re: How to keep Filters active even after changing dimensions

I created a new Module 'Time Filters' but still, I don't find that appearing in the filter view in the working module.

 

SudhirY_0-1619540811987.png

 

ChrisHeathcote
Community Boss

Re: How to keep Filters active even after changing dimensions

@SudhirY 

The time periods need to be the same between the filter module and the target.

If the module to be filtered is in years then the filter module must also be years. 

If your second module uses a different time period then you will need to create a time filter using this time period.

Are they the same?

Chris Heathcote
Bedford Consulting

Gold Partner and Regional Partner of the Year 2021, EMEA
SudhirY
Contributor

Re: How to keep Filters active even after changing dimensions

They are the same time dimensions - Model Calendar - Months.

SudhirY
Contributor

Re: How to keep Filters active even after changing dimensions

Thanks, @ChrisHeathcote for the earlier response. We figured out the issue is driven by the Brought Forward selection. If we disable it then Time Filter module is visible. In the scenario I'm handling I need to use the Brought Forward feature.

 

How do we overcome this issue as we need to publish few saved views in a dashboard for user input?

 

#Broughtforward #Timefilters

SudhirY
Contributor

Re: How to keep Filters active even after changing dimensions

To fix the issue we had to use a new line item in time filter module with Brough Forward feature enabled and it worked!