Import without errors and warnings (extra columns in headers and times)

AntonMineev
Certified Master Anaplanner

Import without errors and warnings (extra columns in headers and times)

Hi community!

I want to bring up the next topic. Best practices and guides suggest that all imports should go with a green check mark, without warning. If there is a warning or an error, then something went wrong and the administrator must intervene.

But I found a case where I don't know how to achieve this without terrible workarounds.

The fact is that I have a template that users unload from the system, fill in and load back. The template has approximately the following columns:


Dimension 1 (code) - used for mapping in action
Dimension 1 (name) - not used in the download, reference information for the user (not everyone knows the codes, it is inconvenient to work with them)
Dimension property 1 (unloaded through labels, used for the convenience of the user when filling out. This can be a mapping to an old dimension or some kind of auxiliary information, such as a store opening date or PL line type)
And several columns in the month-year format (our anaplan time).


An example of such a template is in the attachment.
The problem is that when setting up the loading mapping, I indicate that the time is in the headers and also explicitly indicate the mapping for column 1 (reference code). At the same time, I need to ignore the additional information, but I cannot configure this, because time measurement has its own special mapping. And I cannot set certain columns to ignore in it.
As a result, extra columns lead to the warning "this element does not correspond to the time dimension". What are some tips to get rid of this warning? At the same time, there is no need to force users to delete unnecessary columns before loading or somehow break the template.

12 REPLIES 12
andrewtye
Master Anaplanner/Community Boss

@ChrisAHeathcote - interesting about the repivoting up the import saved view. will give this a go for some of our more complicated exports/imports.

ArunManickam
Master Anaplanner/Community Boss

I know its not a great solution, train the users to delete the property column, or any column that is not date before upload.

 

Thanks

Arun

AntonMineev
Certified Master Anaplanner

Thank you all for your participation!
I was hoping that there is some not obvious way to ignore some of the elements in the time mapping. Unfortunately, there is no such way 🙂

I will systematize all the solutions that have been proposed at the moment:


1. Delete unnecessary columns before loading the template.
2. Use an add-on.
3. Make a template pivot to place the time in rows (instead of columns).

 

I wrote an idea in the community about changing the import settings.