Importing and Exporting Data

Aigboe01
Contributor

Importing and Exporting Data

Hi all,

This is not working for me(The employee Details).

I have selected various combinations for mapping but report not coming right.

Guide me on the correct details to map please from the attached.

Thanks in anticipation!

Regards,

Eboseremen

 

1 ACCEPTED SOLUTION

Accepted Solutions
AlejandroGomez
Master Anaplanner/Community Boss

Re: on the uRe: Importing and Exporting Data

Alright, lets make the following:

  1. first make sure that your employee list has codes, so Anaplan will match the employee codes in your source file(Eg: 1,2,3...) to the actual employee list  (Note: this does not seem to be an error so far). If you do not have codes in your employee list, then use names (Column 1 in your source file).
  2. also, make sure that all the line items in your target module are properly formatted, so they can host the type of data you want to load into them. (Eg: text, list, number, date...)  (Note: this does not seem to be an error so far). In case of doubt make them all "text" except for numbers, dates or booleans. 

Points 1 and 2 perhaps are not really needed in your case, but is better to err on the side of caution and I would recommend you to double check them anyways. Now: 

  1.  In your third tab in the data mapping window (called "SYS08 Employee Details Line Items") select the option "map items manually".
  2. After selecting "map items manually" you will be able manually map the missing fields: Employees, Country and Department as per indicated on the picture below.
  3. additionally,  choose an option called "ignore unmapped items". Select it in order to ignore all the source items that won't be mapped to a line item of your target module. Seems like the only ignored source field will be "Active?" for now.
  4. Finally, for the "date" formatted line items, click the boxes highlighted below to make sure that the date format in your source file is recognised by Anaplan

AlejandroGomez_0-1632782393145.png

 

 

After following these steps, I do not think you will run into new errors. 

View solution in original post

6 REPLIES 6
AlejandroGomez
Master Anaplanner/Community Boss

on the uRe: Importing and Exporting Data

Hi, "Sys08 employee details" in target should be mapped to "column headers" instead of to "column1: employees". Then, on the third of the three tabs on the upper part of the mapping window, make surs that each of the column headers is correctly mapped to the line items of your target module.

 

Cheers

Alex

Aigboe01
Contributor

Re: on the uRe: Importing and Exporting Data

Thanks Alex,

I have mapped code E2 and Column header for SYS08 details.

The result still shows errors in the dats.

See attached.

Regards,

Eboseremen

AlejandroGomez
Master Anaplanner/Community Boss

Re: on the uRe: Importing and Exporting Data

Could you please attach a pic of the mapping you have used in the line item tab? Here:

AlejandroGomez_0-1632774037959.png

 

Thanks

Aigboe01
Contributor

Re: on the uRe: Importing and Exporting Data

Hi Alex,

See attached as requested.

Regards,

Eboseremen

AlejandroGomez
Master Anaplanner/Community Boss

Re: on the uRe: Importing and Exporting Data

Alright, lets make the following:

  1. first make sure that your employee list has codes, so Anaplan will match the employee codes in your source file(Eg: 1,2,3...) to the actual employee list  (Note: this does not seem to be an error so far). If you do not have codes in your employee list, then use names (Column 1 in your source file).
  2. also, make sure that all the line items in your target module are properly formatted, so they can host the type of data you want to load into them. (Eg: text, list, number, date...)  (Note: this does not seem to be an error so far). In case of doubt make them all "text" except for numbers, dates or booleans. 

Points 1 and 2 perhaps are not really needed in your case, but is better to err on the side of caution and I would recommend you to double check them anyways. Now: 

  1.  In your third tab in the data mapping window (called "SYS08 Employee Details Line Items") select the option "map items manually".
  2. After selecting "map items manually" you will be able manually map the missing fields: Employees, Country and Department as per indicated on the picture below.
  3. additionally,  choose an option called "ignore unmapped items". Select it in order to ignore all the source items that won't be mapped to a line item of your target module. Seems like the only ignored source field will be "Active?" for now.
  4. Finally, for the "date" formatted line items, click the boxes highlighted below to make sure that the date format in your source file is recognised by Anaplan

AlejandroGomez_0-1632782393145.png

 

 

After following these steps, I do not think you will run into new errors. 

View solution in original post

Aigboe01
Contributor

Re: on the uRe: Importing and Exporting Data

Thanks Alex for your detailed feedback.

It worked for me. See attached the report