Invalid private key alias with ANAPLAN Connect

Nikola
New Contributor

Invalid private key alias with ANAPLAN Connect

Hi there,

 

I am trying to get an Import done with anaplan connect on windows. I've got to go the way with certificate authentication so I've followed the instructions in ANAPLAN Doc (https://s3.amazonaws.com/anaplanenablement/Community/Anapedia/Anaplan_Connect_v1_4_4.pdf) on Site 11 Option2:CreateaJavaKeyStore. I've done everything what was explained in the linked video (https://community.anaplan.com/t5/On-Demand-Courses/Certificate-Authentication-Process/ta-p/74752)

 

After Running the .bat file on windows I get following Error in the command prompt:

Anaplan API: Could not intialise service credentials (Anaplan API: Invalid Private key alias provided! (Unrecoverable key: Cannot recover key))

I am not quiet sure whats meant with the private key alias. The only alias I've written down in the .bat file is the KeyStoreAlias.

Can someone explain me what causes this error? And maybe how I can fix it?

 

Greetings,

Niko

7 REPLIES 7
Stacey_Gibbens
Certified Master Anaplanner

Re: Invalid private key alias with ANAPLAN Connect

Hi Nico,

I can surely empathize with difficulties getting the CA cert working with Anaplan Connect.  I actually ended up getting personalized help from the folks at Anaplan, as we were early adopters in 2018.

Although I am unsure what is actually at issue with your process, I wondered if you've loaded your certificate public key to Anaplan Administration, under Security --> Certificates?  If not, that's likely the issue.

If you continue to have an issue, I would open a ticket with Anaplan.  They have level 2-3 support that will help you. They helped me a lot.

Good luck!!

Stacey

u06gr8
Contributor

Re: Invalid private key alias with ANAPLAN Connect

Also seeing a similar issue with keystore alias.

 

Cert is uploaded (with public key) in the "Administration, under Security --> Certificates".

 

Did you find a fix?

Stacey_Gibbens
Certified Master Anaplanner

Re: Invalid private key alias with ANAPLAN Connect

What version of Anaplan Connect are you both using?  I assume the newest (1.4.4)?  My implementation is 1.4.2 and I've been considering when to migrate to 1.4.4 in order to gain access to the new functionality...

This would certainly be an interesting bug...  Please keep us all updated!

Thanks!

Stacey

u06gr8
Contributor

Re: Invalid private key alias with ANAPLAN Connect

Yes, 1.4.4 here, albeit 2.0.0 has just been released.

 

I'll keep you informed. Working on this one as an aside, as well as raising through Support also.

 

Greg

Stacey_Gibbens
Certified Master Anaplanner

Re: Invalid private key alias with ANAPLAN Connect

Oops.  I meant to say 2.0.0 not 1.4.4.  I'm giving it a little soak time to make sure I'm not the guinea pig this time...  My customers are really excited about some of the new features (as am I!) but I'd like it to be stable and vetted first!

 

Thanks!

Stacey

Nikola
New Contributor

Re: Invalid private key alias with ANAPLAN Connect

Hi Stacy,

 

thank you for your fast reply.

It's likely that the error I got was because of the missing public key in the anaplan administration.

 

I just tried to upload the public key where you described it (https://help.anaplan.com/b7b8331e-8460-4cff-a337-1b326950f518-Manage-your-Certificates)

I attached a screenshot of an error as well as the public key with some information blurred.

 

Do you have any idea whats the issue here? The .pem file doesn't look wrong to me.

 

Niko

Stacey_Gibbens
Certified Master Anaplanner

Re: Invalid private key alias with ANAPLAN Connect

@Nikola  Pretty sure you just need to delete everything above and below the body of the certificate (begin/end) delineation lines in the file, so the file ONLY contains:

-----BEGIN CERTIFICATE-----

body of public key

-----END CERTIFICATE-----

 

no extra character returns, etc.  Give that a try!   🙂

Stacey