Highlighted
New Contributor

Is Something Wrong With my Role List? Level 1

Hi, 

 

So while trying to update my Emp02 Employee Expenses module calculations for bonus, car costs, phone costs and medical costs to reference Emp03 Employee Drivers by Role module, I get this error: 

 

"Invalid error for 'EMP02 Employee Expenses'.Bonus: Automatic sum of 'EMP03 Employee Drivers by Role'.Bonus % over Role Hierarchy is not possible as Role does not have a built-in top level"

 

I'm guessing the issue stems from my Role list configuration because from my General list pane, my Role list doesn't have any text in the top-level box or in the parent box. What could I be doing wrong? 


I attached a picture of the error message. 

17 REPLIES 17
Highlighted
Master Anaplanner/Community Boss

Re: Is Something Wrong With my Role List? Level 1

@sosunkwo 

Not sure what you're looking at there or what your loading but I think you're close to the answer.

Can you refer to the instructions when you were first asked to build the role list - also check data hub and spoke application?

If the list is in the data hub the list should be flat.

In your spoke application you may need to add a top level.


Jared Dolich
Highlighted
New Contributor

Re: Is Something Wrong With my Role List? Level 1

@Jared Dolich, I'm curious as to why I'm getting the error message described in my first post. 

Highlighted
Master Anaplanner/Community Boss

Re: Is Something Wrong With my Role List? Level 1

@sosunkwo ,

 

In order to do a sum, the list must have a Parent member or Top level defined, this is why you are getting that error.  To fix this, in the Roles list, you can put in All Roles as the Top Level item.

 

Rob

Highlighted
New Contributor

Re: Is Something Wrong With my Role List? Level 1

@rob_marshall 

 

So I tried typing in top level box, but it gave me this error. (attached)

Highlighted
Master Anaplanner/Community Boss

Re: Is Something Wrong With my Role List? Level 1

@sosunkwo 

You have a list item that has that name.

Delete that out of your list first. Then add All Roles to the top level.


Jared Dolich
Highlighted
New Contributor

Re: Is Something Wrong With my Role List? Level 1

@Jared Dolich 

 

I want to make sure I understand you correctly. So delete where it says "All Roles" at the bottom of the Grid View of the Roles List? (Pls. see attachment)

Highlighted
Occasional Contributor

Re: Is Something Wrong With my Role List? Level 1

Based on your image, I see that the Parent column in empty. I would just add "All Roles" to the Parent field for all the line items.

Highlighted
New Contributor

Re: Is Something Wrong With my Role List? Level 1

@aashca9 

 

I actually just took that out now to see if it would clear things up. It has been there previously. Either way I still get the error message in my initial post. (pls see image)

Highlighted
Occasional Contributor

Re: Is Something Wrong With my Role List? Level 1

One more thing I would mentioned is to make sure that your "Configure" tab looks like the one I attached. I see your list and I don't see a roll up.03032020.JPG