Highlighted
Certified Master Anaplanner

Issue importing dates as text

Hello,

 

I'm trying to import a date into a text-formatted property from a source file.  This works on my machine, however when another user uploads the same file, it seems to be creating a text field which includes 2 digits for the year vs. 4.  So, when I run the import, the text-formatted field reads "12/31/2018", but when someone else runs the same file, it reads "12/31/18".  Does anyone know why this is happening?  I've had the user send me the source file that they are using, and it still shows with the 4 digit date on my machine, but 2 digits when he uploads that file. 

Since I'm using this property as part of a "combination of properties" to create a unique ID, this is a very important item.

 

Thoughts?

 

Thanks,

Josh

1 REPLY 1
Highlighted
Master Anaplanner/Community Boss

Re: Issue importing dates as text

@jbrass,

 

I believe the issue is with Excel and the different settings you and your co-worker have on each machine.  Try this, convert the date column to a text column and then try the import again.  Lastly, I would not advise using the date to make the "record" unique as this simply inflates the list.  Instead, try to find another combination of fields to make it unique, use that as your "code", and then import the trans data to a trans module (list by Time).  In another module that is not defined by time (so it is just the list), you can have formulas determine the attributes.  For example, if your code is 100_200_300_400, those would be "codes" of different lists (Channels, Account, Cost Center, etc.).  We have found this will actually speed up the imports as well as the model open time.

 

Hope this helps,

 

Rob