Level 1 Model Building Certification Exam EMP 03 Formula Error

Highlighted
Occasional Contributor

Level 1 Model Building Certification Exam EMP 03 Formula Error

Hi,

I am trying to complete the certification exam and have come to question #4. I am trying to change EMP02's formulas from referencing EMP01 to EMP03 but when I do I receive an error.

 

The formula I am using is:

 

IF Employed? THEN Salary * 'EMP 03 Employee Drivers by Role'.Medical Benefit [LOOKUP: 'SYS08 Employee Details'.Department, LOOKUP: 'SYS08 Employee Details'.Role] ELSE 0

 

But I get an error saying "Data type mismatch: format other than LIST or DATE being referenced as a relation"

I cannot for the life of me figure out what to do here. Any help would be greatly appreciated.

15 REPLIES 15
Highlighted
Master Anaplanner/Community Boss

Re: Level 1 Model Building Certification Exam EMP 03 Formula Error

@Wg689033 

 

Check the format of the below line items

 

SYS08 Employee Details.Department - Department line has to be formatted on Department List

SYS08 Employee Details.Role - Role line item has to be formatted on Role list

 

Looks like format of these two line items are not Lists

 

Thanks,

Misbah

Highlighted
Occasional Contributor

Re: Level 1 Model Building Certification Exam EMP 03 Formula Error

I believe they are formatted correctly. Maybe my error is in the formatting of Medical Benefit? I have attached images to show you what my formats look like.

Highlighted
Master Anaplanner/Community Boss

Re: Level 1 Model Building Certification Exam EMP 03 Formula Error

@Wg689033 

 

They are not formatted correctly. See below

 

Role is text formatted when it should be list formatted

 

Misbah_0-1583516234569.png

 

Highlighted
Occasional Contributor

Re: Level 1 Model Building Certification Exam EMP 03 Formula Error

Okay so I formatted Role to #E2 Employees and tried again and received an error that says:

"Format of mapping used for lookup doesn't match any dimension of the source"

am I making progress or did I break something else? 

 

I appreciate the help!

Highlighted
Master Anaplanner/Community Boss

Re: Level 1 Model Building Certification Exam EMP 03 Formula Error

You need to format the line item to Roles list and not E2 employees list. When you click on the format option make it list format and then from available options from the dropdown pick Roles and not E2 employees. You should be good.
Highlighted
Occasional Contributor

Re: Level 1 Model Building Certification Exam EMP 03 Formula Error

Ah Finally got it, I greatly appreciate the help 🙂 

Highlighted
New Contributor

Re: Level 1 Model Building Certification Exam EMP 03 Formula Error

I had the same problem as well... This thread was very helpful 🙂

Highlighted
Occasional Contributor

Re: Level 1 Model Building Certification Exam EMP 03 Formula Error

I am having an issue with the Role list as well. When I try to format the Role line item in SYS08 it gives me this error: Format of mapping used for lookup doesn't match any dimension of the source.

 

I've had no luck fixing this issue. Do you have any suggestions?

 

Thank you!

Highlighted
New Contributor

Re: Level 1 Model Building Certification Exam EMP 03 Formula Error

I'm lost here...I believe I reformatted the Role line item to the roles list, but the error message is the same. Anything obviously wrong with this screenshot?

 

Kbassett_0-1592492633754.png