Level 1 Model Building SYS08 Employee Details Import Issue

Contributor

Level 1 Model Building SYS08 Employee Details Import Issue

 

We are asked to import Emloyees.csv into SYS08 Employee Details and I am unable to get the names in the list to match on the names in the employees list that I already have in. I checked and I have the data type as "Text" listed within the SYS08 module, and the .csv has the data in that column listed as "General". I also tried changing that to "Text"; neither work. I can do it manually but it will take a long time.

 

Is there something I'm missing or should consider?

 

 

 

Import Problem.PNG

20 REPLIES 20
Highlighted
Community Boss

Re: Level 1 Model Building SYS08 Employee Details Import Issue

Hi,

 

in the first tab, Mapping, which field are you using to map the Employee ? You should be using the code, not the name.


Nathan Rudman, Anaplan Model Builder
Highlighted
Contributor

Re: Level 1 Model Building SYS08 Employee Details Import Issue

Thanks for the response. Here are some more screenshots:

 

This first one shows the mapping that corresponds to the screenshot from the original post.

mapping1.PNG

 

 

This second one, I believe, follows how you are implying I should be mapping.

 

Mapping2.PNGThis third one shows what I see when I use the Mapping set up from the second screenshot. It still doesn't seem to be working. 

 

Mapping3.PNG

 

What am I missing? Thanks in advance!

Highlighted
Master Anaplanner/Community Boss

Re: Level 1 Model Building SYS08 Employee Details Import Issue

Hi,

 

#E2 Employee is a number list, so we can't use the name for mapping. We should use code for the import.

 

Your mappings are right, please download the file again and try to load it.

 

Regards,

Vignesh M 

Highlighted
Community Boss

Re: Level 1 Model Building SYS08 Employee Details Import Issue

your mapping is correct here.
The reason why it is not working is probably because your employee list doesn't have the code set up (you might have missed it when creating it). Re import the employee list with the code and it will work

Nathan Rudman, Anaplan Model Builder
Highlighted
Contributor

Re: Level 1 Model Building SYS08 Employee Details Import Issue

Here is a screenshot of my employee list, where you can see that each employee does have a code associated with them. Do you recommend that I clear out this list and attempt to repopulate it?

 

EmployeeList.PNG

Highlighted
Community Boss

Re: Level 1 Model Building SYS08 Employee Details Import Issue

no that's the right code.
But you can see in the data you have, the code is not 001 but 1, so Anaplan cannot match it.
That usually happens when you open the CSV file with excel and save it, then import the saved CSV. Re-download the CSV from the training and reload that file, without opening/saving in Excel

Nathan Rudman, Anaplan Model Builder
Highlighted
Contributor

Re: Level 1 Model Building SYS08 Employee Details Import Issue

That appears to have done the trick - good catch. Here is a screenshot of what it looks like now that it has successfully uploaded and matched the codes:Solution.PNG

Highlighted
New Contributor

Re: Level 1 Model Building SYS08 Employee Details Import Issue

Hi Team,
I am able to import the data but getting below error, could anyone help me on this...

 
 

SYS08 Error.png

 

Highlighted
Certified Master Anaplanner

Re: Level 1 Model Building SYS08 Employee Details Import Issue

@anihnmails 

 

On the mapping for the import, are you using "Code" as the source for the #E2 Employees target?  If using the Employees column, this will not map to items in the target list as it is a numbered list and the employee name is for display purposes only (the actual list element is a number value assigned within Anaplan).  When importing data it is generally best to use a code value if one exists, names can change but a code value should remain constant.