Highlighted
Master Anaplanner/Community Boss

Re: Level 1 Model : Dimension of mapping used for lookup doesn't match any dimension of the result.

@Joruss75 ,

 

A couple of things, you should not have subsidiary views defined (the little icon after the line item in your picture).  That happens when the dimensionality of the line item is not the same as the what has been defined for the module.  Secondly, I am not sure where E3 Roles list came from, Roles should be a flat list.  Lastly, the module should look like the below.

 

2019-12-17_06-38-17.png

Highlighted
New Contributor

Re: Level 1 Model : Dimension of mapping used for lookup doesn't match any dimension of the result.

Hi there, 

 

I was able to input all of the different formulas into the REP04 module, however for the list item 'Bonus' I was unable to have any output results. Across all Roles and Regions it shows a '0' in the years. Any chance you can help, thank you!

 

Highlighted
Contributor

Re: Level 1 Model : Dimension of mapping used for lookup doesn't match any dimension of the result.

hI @ifeldman,

Is the error (no data) only for line item Bonus?

REP04 module is reporting summary of employee expense by Role across Region; Source data for this report is referenced from EMP02 module (employee expenses). Some probing questions...

  1. Is there data in source module?
  2. Do you notice that dimension of Source module and Target module are not same?
  3. Whats the additional dimension in your Target?
  4. Is there a mapping table (where relationship is maintained) you can reference to sum-up, for the additional dimension in target?
  5. Is there parent-child relation between Region & Employee? 

Kindly check. 

Cheers!

Highlighted
New Contributor

Re: Level 1 Model : Dimension of mapping used for lookup doesn't match any dimension of the result.

Hi, I am doing the same thing right now and I am getting the same error. Do you by any chance recall which of your datatype was incorrect?
Highlighted
New Contributor

Re: Level 1 Model : Dimension of mapping used for lookup doesn't match any dimension of the result.

Hi @usman.zia,

 

Thank you !

 

I had created a EMP03 Module "Employee Drivers by Role" as instructed. Please find the attached screenshot for the same.   

 

Now where we will get the Data file to import into this module and we don't have role as a line item.What relationships we need to create in  SYS.08 Employee Details Module to resolve this? Before using this below mentioned formula,

 

Bonus - IF Employed? THEN Salary * 'EMP03 Employee Drivers By Role'.Bonus %[LOOKUP: 'SYS08 Employee Details'.Department, LOOKUP: 'SYS08 Employee Details'.Role] ELSE 0

 

what other steps I need to follow to build the relationship in SYS.08 Employee Details.

Highlighted
Master Anaplanner/Community Boss

Re: Level 1 Model : Dimension of mapping used for lookup doesn't match any dimension of the result.

Hi @rahulharjai 

 

I have attached an image of the blue print for the sys.08 module.

 

You will need to import the data for line items that have no formula and make sure you have used the correct line item formats to enable the formula to work correctly. 

 

I hope this helps! 

 

Thanks,

 

Usman

Highlighted

Re: Level 1 Model : Dimension of mapping used for lookup doesn't match any dimension of the result.

Hi Usman -

I am having a similar issue than Joruss below.  When I try to build the formulas in EMP02 for the bonus, car allowance, etc I get the message: "Data type mismatch: format other than LIST or DATE being referenced as a relation".

 

I understand this to be an issue with my EMP03 data type not matching something, but unlike Joruss I can't figure out how to fix the data type.

 

Attached are the screenshots for the various modules and error message.

 

Thanks in advance for your help,

RP

Highlighted
New Contributor

iRe: Level 1 Model : Dimension of mapping used for lookup doesn't match any dimension of the result.

Hi I have done what you said and checked Sindy which was correct, but the figure I get for Medical for Finance in Dec is wrong. 36800. I am doing something wrong I just dont know what

Highlighted
Occasional Contributor

Re: Level 1 Model : Dimension of mapping used for lookup doesn't match any dimension of the result.

Spoiler
 

I had entered what I believed to be the correct formula, and after reading your response, I had typed the formula correctly (it matched what you listed), however, I am getting this error:

 

Invalid formula for 'EMP02 Employee Expenses'.Bonus: Automatic sum of 'EMP03 Employee Drivers by Role'.Bonus % over E3 Role hierarchy is not possible as E3 Role does not have a built-in top level

 

Any ideas would be appreciated!

Thank you!

Highlighted
New Contributor

Re: Level 1 Model : Dimension of mapping used for lookup doesn't match any dimension of the result.

Hi @Misbah 

 

Please find the attached screenshot for EMP02 Dimensions.

 

Thanks