Line Items that Do Not Need Time Dimension Appear Blank in Grid View for Some Modules

jspascual
Contributor

Line Items that Do Not Need Time Dimension Appear Blank in Grid View for Some Modules

Hello, 

 

I would like to ask and gather some feedback on the situation I am having regarding the above subject line. 

 

I find it strange that a module which has a line item that does not need a time dimension (it's set to Not Applicable) shows the information and the other module does not. 

 

For example, in module A, I have a line item "CS1", it is a text, and therefore does not need time dimension so I set it to Not Applicable, it is showing the "CS1" on each row, this is fine. However, I also have a module B, which has the same setup as a line item, I also set it as Not Applicable for the Time, but it's NOT showing the information. 

 

This is affecting model optimization since Time Dimension when used increases the size of the module.

In addition, it's affecting the list being generated because I'm using the said line items as well as part of unique identifiers in the schedule I'm generating text files for. A lot of times, I'm getting the error, "A same key has already been added" - it's because the line item in issue does not show the information in the module which causes the information to be not unique. 

 

For illustration:

 

This is the module that shows the information even if the line items are set to Not Applicable for the Time:

 

jonathanpascual_0-1580728650355.png

 

Here's how it looks in the grid view, it has the information for the said line items:

 

jonathanpascual_2-1580729043933.png

 

And this is the module where the line items using the same setup as the above Time Scale, they do not show in the grid view: 

 

jonathanpascual_1-1580728951964.png

jonathanpascual_3-1580729088343.png

 

Any ideas? 

 

Thanks a lot.

 

Jonathan

 

4 ACCEPTED SOLUTIONS

Accepted Solutions
Misbah
Moderator

Re: Line Items that Do Not Need Time Dimension Appear Blank in Grid View for Some Modules

@jspascual 

 

Is there any Dynamic Cell Access applied to these line items? 

 

 

View solution in original post

Akhtar.shahbaz
Community Boss

Re: Line Items that Do Not Need Time Dimension Appear Blank in Grid View for Some Modules

@jspascual 

 

I have tried to replicate your problem, one possible reason may be because of DCA.

Please find below the screenshot for your reference

1. DCA is applicable for both line items then it will show the value.

Screenshot_1.png

Screenshot_2.pngScreenshot_3.png

 

2. when both write & read access for DCA is blank

 

Screenshot_4.png

 

Screenshot_5.png

 

 

Better to have a formula in your DCA line items for toggle between the Write & Read access.

I hope that helps

 

 

Thanks

Akhtar

 

 

View solution in original post

jspascual
Contributor

Re: Line Items that Do Not Need Time Dimension Appear Blank in Grid View for Some Modules

@Akhtar.shahbaz , Thank You so much.

 

I was about to update this thread as well. I found out that there were read/write access at the module level. 

I then tried to remove that from the line items  and it worked. 

 

jonathanpascual_0-1580987410000.png

 

 

Thank you again, everyone! 

 

Jonathan 

View solution in original post

jspascual
Contributor

Re: Line Items that Do Not Need Time Dimension Appear Blank in Grid View for Some Modules

Finishing this thread with a logical reason why it behaved that way on my model...

 

All of the comments were extremely helpful, thanks everyone! The DCA was the reason why it was behaving that way. 

 

I have this module called "Control Access" which is for the read/write access for the modules and it has a Time Dimension - "Month".

So naturally, when there is a read/write access restriction, and the line items in the module problem are set to "Not Applicable" time, it could not see it. So the resolution was to remove the read/write access in the specific line items that do not need time dimension.

 

Thanks all! 

 

Jonathan

View solution in original post

15 REPLIES 15
ben_speight
Super Contributor

Re: Line Items that Do Not Need Time Dimension Appear Blank in Grid View for Some Modules

Check versions applicability and summary methods in the first instance - do the data grids present summary-level information, what is in the page selectors.

Misbah
Moderator

Re: Line Items that Do Not Need Time Dimension Appear Blank in Grid View for Some Modules

@jspascual 

 

As @ben_speight  suggested Check your Summary settings. It should be kept as anything but None.

 

Thanks,

Misbah

jspascual
Contributor

Re: Line Items that Do Not Need Time Dimension Appear Blank in Grid View for Some Modules

Thanks for the comments, @Misbah , @ben_speight 

 

I tried First Non-Blank, Last Non-Blank, and Formula as the Summary Settings but still did not show the information in Grid View.

The other module has Formula as the Summary Settings and does show the information in Grid View just fine. 

In addition, they both have no Applies To and strangely, they do not work similarly. 

 

Any other ideas?

 

Thanks,

 

Jonathan

Misbah
Moderator

Re: Line Items that Do Not Need Time Dimension Appear Blank in Grid View for Some Modules

@jspascual 

 

Can you please share snapshot of the blueprint mode of both the modules. And also the snapshot of the front end about the selections that you are making

 

Thanks,

Misbah

jspascual
Contributor

Re: Line Items that Do Not Need Time Dimension Appear Blank in Grid View for Some Modules

Spoiler
 

Here's the module that does not work:

 

jonathanpascual_1-1580807736581.png

 

And here is the module that works using the same setup:

 

jonathanpascual_2-1580807781985.png

 

Thanks!

 

Jonathan

AWhitworth
Certified Master Anaplanner

Re: Line Items that Do Not Need Time Dimension Appear Blank in Grid View for Some Modules

Do the lists in the module level Applies to both have a top level assigned? 

JaredDolich
Moderator

Re: Line Items that Do Not Need Time Dimension Appear Blank in Grid View for Some Modules

@jspascual 

 

You might try using TIMESUM which will sum up values for you nicely.

Someone else had the same issue a while ago. See the post here.

 

Generally speaking, it's a good idea to avoid using subsidiary views unless for filtering (see Planual by @davidsmith)  See 2.01-06

And @rob_marshall reaction to subsidiary views here.


Jared Dolich
jspascual
Contributor

Re: Line Items that Do Not Need Time Dimension Appear Blank in Grid View for Some Modules

Thanks for the response, @JaredDolich .

 

The line items in issue are in text format, TIMESUM is not an option:

 

jonathanpascual_0-1580865589015.png

 

I am only using the line items for the purpose of generating an output file with the exact format needed for the project. 

The other module with the same setting works fine and I find it strange that it's not working on this module. 

 

The only option that works is to put a Time - Month and it shows up:

 

jonathanpascual_0-1580865904773.png

 

jonathanpascual_1-1580865976771.png

 

Thanks!

 

Jonathan

 

 

 

Egor
Certified Master Anaplanner

Re: Line Items that Do Not Need Time Dimension Appear Blank in Grid View for Some Modules

Hi Jonathan,

 

Indeed, very odd case, if the line item has no dimensions, Summary Method should not affect how it is reflected in the module.

 

A few things I would try to find the root cause:

 

1. Ensure your Formula Scope is set to All Versions (if it is set to Current Version in a non-versioned line item - the formula will not work, although this error would not be fixed by adding time dimension)

2. Check the subsidiary view of AAHC line item, and see if the value is at least reflected there both when time dimension is applied and when it is not (this will help to identify if there is a problem with a formula or a summary method)

 

Please keep us posted, I am very curious to see what the issue might be 🙂

 

Best regards,

Egor.