Model Builder Level 1

Jacob3
Contributor

Model Builder Level 1

Hi,

I am new to Anaplan and have just started the Level 1 Model Builder course. I am in the Activity 7.2.3 section and have been stuck for a few hours now.

Need some help to find out what I am doing incorrectly.

I have attached a few screenshots

Appreciate  help from the community.

Thanks

Jacob

1 ACCEPTED SOLUTION

Accepted Solutions
Jacob3
Contributor

Re: Model Builder Level 1

I changed the format in the Code line to text and it worked.

 

Thanks Tiffany

View solution in original post

12 REPLIES 12
Tiffany.Rice
Certified Master Anaplanner

Re: Model Builder Level 1

@Jacob3  - Try modifying the source to target mapping on the import.  E2 Employees# should map to the code - this is the unique identifier that indicates which employee is being referenced in the data.  Line items should be mapped to column headers.

Jacob3
Contributor

Re: Model Builder Level 1

Hi Tiffany,

I modified the source to target on the modifying at the import. But do not think I have got it right. I mapped the E2 Employees# mapped to the code. The Country details and SYS08 details is not correct. Not sure how to fix.

 

I have attached the updated screenshots.

 

Appreciate all your help.

Tiffany.Rice
Certified Master Anaplanner

Re: Model Builder Level 1

@Jacob3 - the blueprint view on SYS08 doesn't look quite right.  You have different "Applied To" on the individual lines but in order for the module to operate as intended you should be applying a consistent dimensionality (i.e. Applies to) through out.  All line items are defining attributes of E2 Employees#.  For highlighted items, set the applies to as a "-" meaning the same list applies to all line items.  

TiffanyRice_0-1630074397875.png

 

Jacob3
Contributor

Re: Model Builder Level 1

Thanks Tiffany.

I made the changes you highlighted and ran it again. Have attached screenshots after updates.

Also what are those little squares besides the List name in the List view. In the course work page that is not present.

 

Another general question - community related. I am not familiar how this community thing works. Is this post viewed such that everyone can view. Reason I asked is, if that was the case I can get help regardless of what time of day/night I post.

 

Tiffany.Rice
Certified Master Anaplanner

Re: Model Builder Level 1

@Jacob3 the little square indicate that the line item is a "subsidiary view" which means it is setup with a different dimensionality then the rest of the module.  If you look at the blue print you will see that the Applies To for those lines is blank - all line items need to be have the same list E2 Employees applied (this is the cause of your import error).  Anaplan will do this by default when you create a new module, these subsidiary views only occur when you change the Applies To in the blueprint mode. 

 

Community posts are open to all members day and night. This is not a manned support line but rather a platform for Anaplan end users to interact and help one another along the way.  Welcome to the community and good luck with your journey to become a model builder!

Jacob3
Contributor

Re: Model Builder Level 1

Thanks for your guidance.

Before I make the changes and run it again I have a question.

Should the "E2 Employees#" be on the SYS08 Employee Details" line (Blueprint view)

Tiffany.Rice
Certified Master Anaplanner

Re: Model Builder Level 1

Yes, the applies to notes on the SYS08 Employee Details line indicates the setup for the module itself.  This would reflect the lists that you selected when you setup the module.  By default this gets applied to every line item unless something else is specifically entered within the applies to section for that line item. See below - this is the correct setup.  The circled bit is what tells you that the default for the module is being applied to the line item. 

 

TiffanyRice_0-1630089152874.png

 

Jacob3
Contributor

Re: Model Builder Level 1

Thanks.

I made all the changes and still have some error msg. Please see attached screenshots.

Tiffany.Rice
Certified Master Anaplanner

Re: Model Builder Level 1

Make sure all line items are mapped in the import action.  See below - highlighted items are not mapped because the column header is not equal to the line item.  Selection option to manually map and then ensure every column header is either mapped to a line item or set to be "ignored" in the import action.  This is a critical step in every import setup action so you will want to get very comfortable with this process and ensure you are reviewing this tab in every import action that you setup. 

TiffanyRice_1-1630091985459.png