Percentage data to high when importing from csv file

hannaaberg
New Contributor

Percentage data to high when importing from csv file

Is seem to have problem with importing data for list items with type percentage.

 

For example, in the Model builder 1 course i try to import data to list item Bonus % in the EMP01 Employee Drivers module. The format looks as follow:

hannaaberg_0-1640792057990.png

 

The data in the csv file is for example 0,12. So this should translate into 12% once imported, but the result that I receive is this:

hannaaberg_1-1640792115401.png

So it seems like it's 100 times higher than it should. What do I do wrong here?

 

4 REPLIES 4
bhatjaved
Frequent Contributor

Re: Percentage data to high when importing from csv file

In this case you can fix the source and convert % column to decimals which will give you correct % in line items or you may create additional line item in module to further divide the source and have percentage line item populated

ChrisAHeathcote
Community Boss

Re: Percentage data to high when importing from csv file

@hannaaberg 

Check the settings in the import to ensure that you are recognising the decimal and thousand separators correctly. 

I suspect the current settings are recognising dot as the thousand separator and comma as the decimal separator. 

Be mindful of the formatting of the source data when importing. 

 

Chris
HeathcoteAndHerran.com
hannaaberg
New Contributor

Re: Percentage data to high when importing from csv file

In which step in the import do I check this? I can only se that this looks OK but there is no way of finding out how Anaplan interprets the actual bonus % data?

 

hannaaberg_0-1640856383796.png

hannaaberg_1-1640856402237.png

hannaaberg_2-1640856503356.png

The decimal point is set to "." and the thousand seperator is set to "," so I don't think that your initial hypothesis holds since the csv has a "."

ChrisAHeathcote
Community Boss

Re: Percentage data to high when importing from csv file

@hannaaberg 

You need to create a new data source by selecting the data source again and reconfiguring the settings. 

Chris
HeathcoteAndHerran.com