Period format in export file.

Ari
Contributor
Contributor

Period format in export file.

Hello, I am saving some export definitions for my client. To print all the codes in a flat .csv export file, I would have to put 4 or 5 dimensions in the rows, but it's limited to 3. Instead, I am using the tabular method with a filter for time and version.
 
The only problem is that when time is transposed Anaplan changes the format of the time from 'Q1 FY20' to 'FY20Q1'. So to work around that, I've put the period in a line item. But now I have the time dimension showing FY20Q1 and the line item printing 'Q1 FY20'.  Why is Anaplan changing the format of the time? Is there a way to get it to export it right so I don't have to put it in a line item? See file attached.
clipboard_image_0.png
 
Thank you for your feedback,
 
Kind regards,
2 ACCEPTED SOLUTIONS

Accepted Solutions
DavidSmith
Community Boss

@Ari 

This could be when you use on of the exceptions for list properties

I'm not sure if it will work in this use case, but if you create list properties for one of the dimensions, you can choose to display them as well as the list name as part of the export

 

Alternatively, you may have to create a fake time list and map the data to that, specifically for the export

 

I hope that helps

David

View solution in original post

VIGNESH.M
Super Contributor

Hi Ari,

There are 2 options,

#1. Create a Fake Time list and use it as dimension instead of anaplan time. 

1.png

OR

#2. Change the view and export, bring the line items to Rows and export it, you will get the right time format.

 

Regards,

Vignesh M

 

View solution in original post

3 REPLIES 3
DavidSmith
Community Boss

@Ari 

This could be when you use on of the exceptions for list properties

I'm not sure if it will work in this use case, but if you create list properties for one of the dimensions, you can choose to display them as well as the list name as part of the export

 

Alternatively, you may have to create a fake time list and map the data to that, specifically for the export

 

I hope that helps

David

VIGNESH.M
Super Contributor

Hi Ari,

There are 2 options,

#1. Create a Fake Time list and use it as dimension instead of anaplan time. 

1.png

OR

#2. Change the view and export, bring the line items to Rows and export it, you will get the right time format.

 

Regards,

Vignesh M

 

Ari
Contributor
Contributor

Hi,

 

Thanks for the replies. I did use a fake time and ignored the time column. I had the confirmation from Anaplan that it is currently the only work around if we want to be using tabular exports. As to why the time dimension was showing up this way, it was confirmed that it's a bug and it's on the Anaplan dev team's list to check.

 

Kind regards,

 

Ari