PlanIQ - failure to add Attributes in Forecast Model

MaciejD
Occasional Contributor

PlanIQ - failure to add Attributes in Forecast Model

Hi Community, 

 

When in PlanIQ I run a Data Collection that contains historical data and attributes, the Data Collection fails. I receive an error message saying that attributes don't include all items in historical data (screenshot attached), which is not true, because I use exactly the same list of items in both historicals and attributes. What could be the reason for that issue?

15 REPLIES 15
Misbah
Moderator

Re: PlanIQ - failure to add Attributes in Forecast Model

@MaciejD 

 

Are all the attributes text formatted?

 

Also 0's in historical data - you may want to remove outliers if they are not actual zeros

MaciejD
Occasional Contributor

Re: PlanIQ - failure to add Attributes in Forecast Model

Hi @Misbah ,

 

Yes, all attributes are text-formatted. 

The zeroes in historical data are true zeroes, indicating that zero items was sold on a given day .

 

Thanks,

Maciej

Misbah
Moderator

Re: PlanIQ - failure to add Attributes in Forecast Model

@MaciejD 

 

And in your export action have you enabled "Row label headers"?

MaciejD
Occasional Contributor

Re: PlanIQ - failure to add Attributes in Forecast Model

@Misbah 

Yes, I did. I use code as an identifier (same as in the export of historical data).

Misbah
Moderator

Re: PlanIQ - failure to add Attributes in Forecast Model

@MaciejD

 

Could you please share the Data Collection Window for Historical data as well as Attributes data?

 

Hope export is in .csv format

Hope there is nothing in related data.

MaciejD
Occasional Contributor

Re: PlanIQ - failure to add Attributes in Forecast Model

@Misbah

 

 Attached are screenshots of Properties of the Data Collection. Is that what you ask for?

There is no Related Data in this collection.

Misbah
Moderator

Re: PlanIQ - failure to add Attributes in Forecast Model

@MaciejD 

As far as I know there should be start date & end date ranges here

 

Misbah_0-1631535934483.png

 

 

MaciejD
Occasional Contributor

Re: PlanIQ - failure to add Attributes in Forecast Model

@Misbah 

 

Well, when I include historical data only, a Data Collection is succesful, and the time/date range is there. 

But when I include also Attributes, data collection fails and there is no time/date range information.

 

Regards, 

Maciej

Misbah
Moderator

Re: PlanIQ - failure to add Attributes in Forecast Model

@MaciejD 

 

I think that is the problem. Your timescale is not identified by PLANIQ.

 

Also make sure that the number of line items in Attributes module do not go more than 10

 

Misbah