Rank Formula Issue - Not Starting at 1

RobinSilk
Contributor

Rank Formula Issue - Not Starting at 1

Hello,

 

I am running into a strange issue with the rank formula. In the attached screenshot, you can see a line item with the formula:

 

RANK(1, ASCENDING, SEQUENTIAL, CURRENT FLAG <> Previous Current Flag, Current Flag Mismatch)

 

I have displayed all related line items. A screenshot of the filter on the view has been provided as well.

 

 

The line item "Current Flag Mismatch" has the formula:

 

CURRENT FLAG <> Previous Current Flag

 

This view is also filtered (screenshot of that attached as well) and sorted ascending for the RANK line item. I am struggling to figure out why the rank starts at 10,293 instead of at 1! This doesn't really seem to make sense. Any help would be appreciated.

 

Thanks,

 

Robin

2 REPLIES 2
Misbah
Master Anaplanner/Community Boss

Re: Rank Formula Issue - Not Starting at 1

@RobinSilk 

 

RANK(1, ASCENDING, SEQUENTIAL, CURRENT FLAG <> Previous Current Flag, Current Flag Mismatch)

Remove the last parameter in the above syntax - one it is not needed, second it is repetitive.

 

Try this

 

RANK(1, ASCENDING, SEQUENTIAL, CURRENT FLAG <> Previous Current Flag)

 

Misbah

RobinSilk
Contributor

Re: Rank Formula Issue - Not Starting at 1

Already tried this, didn't work. I did find the issue though:

 

unparented items in the list (orphans)

 

Although you cannot see them in the module, they were being counted by the formula. Deleting out these items would presumably fix the issue.