Running an Action to Export with a Mapping from Informatica

jmejia
Occasional Contributor

Running an Action to Export with a Mapping from Informatica

Hi,

 

I'm trying to execute an Action to export data with the use of a Mapping in Informatica. I've executed many exports with mappings in the past, but for some reason with this action, I'm only receiving the headers. There are no rows of data.

 

The strange thing is that when I run this action directly in Anaplan I get the rows of data without issue.

 

Any advice is appreciated.

Jorge

1 ACCEPTED SOLUTION

Accepted Solutions
jmejia
Occasional Contributor

Re: Running an Action to Export with a Mapping from Informatica

Looks like the service account that Informatica was using had an expired password. Resetting the password enabled the action to export data, not just headers. Strange though because in the past when this is the case, the validation fails in Informatica and you are unable to run the action entirely. I'm not sure why Informatica behaved this way this time around.

 

Thank everybody.

Jorge

View solution in original post

6 REPLIES 6
JaredDolich
Moderator

Re: Running an Action to Export with a Mapping from Informatica

@jmejia 

Try this: There's a good chance the default export is from a prior save. Anytime you change the saved view you must manually rerun the export action and save as "All". Make sure you name the export the same as before. Then try again. With exports using the API (or with Informatica, same) there are two parts to an export. The first is to create the export action, the second is to download the data. Sometimes these two get confused as being one and the same.

If this doesn't work, make sure the email (User) you're using in Informatica has the security to see the data you're after. Could be a simple selective access issue.


Jared Dolich
jmejia
Occasional Contributor

Re: Running an Action to Export with a Mapping from Informatica

Thanks for the advice  @JaredDolich but unfortunately after executing your suggestions the export still only has headers. This is the first time I've had an issue like this with a seemingly straight forward export action.

 

Jorge

ashish.banka
Super Contributor

Re: Running an Action to Export with a Mapping from Informatica

@jmejia Just wondering, when the run the export from Anaplan platform, does it shows data along with header?

 

~AB

jmejia
Occasional Contributor

Re: Running an Action to Export with a Mapping from Informatica

@ashish.banka Indeed. When executing in the Anaplan platform, I receive the full export (headers & rows).

 

Jorge

JaredDolich
Moderator

Re: Running an Action to Export with a Mapping from Informatica

@jmejia 

It's possible it's an Informatica issue. One idea that I used a while ago was to delete the Informatica process and rebuild it. If that's possible without a lot of disruption you can try that too. Beyond that, I would say it's time to pull in the support@anaplan team.


Jared Dolich
jmejia
Occasional Contributor

Re: Running an Action to Export with a Mapping from Informatica

Looks like the service account that Informatica was using had an expired password. Resetting the password enabled the action to export data, not just headers. Strange though because in the past when this is the case, the validation fails in Informatica and you are unable to run the action entirely. I'm not sure why Informatica behaved this way this time around.

 

Thank everybody.

Jorge

View solution in original post