Set Date by Time Zone

Highlighted
Previous Contributor

Set Date by Time Zone

I'm based in the UK but all the dates in Anaplan come up in the US format mm/dd/yy rather than the UK format dd/mm/yy. Is there anyway I can change this? Using a UK computer, however, when I type a date into Excel it comes up as dd/mm/yy as a default.  Do you know how I can check?

6 REPLIES 6
Highlighted
Previous Contributor

RE: Set Date by Time Zone

The dates should follow your system date settings on your computer. There should be a setting in control panel of your Windows computer to validate. You should be able to change the date display format there. We have also found during testing here we have found that date formatting varies between browsers. And also between OS i.e. Windows / Mac and others. Some browsers use the setting in Windows 'Control Panel', whereas others have to have the language installed in browser preferences. For details on how to change the date format in your browser settings, go to https://community.anaplan.com/anapedia/around-the-platform/settings-tab/time#date-format
Highlighted
Previous Contributor

RE: Set Date by Time Zone

I'd like to bump this up as I have had a similar issue, but doesn't warrant a new thread. When importing dates into Anaplan (without the time dimension), it has defaulted to the US format of mm/dd/yy. The bizarre thing is that the month before (around 1 June), it imported fine so is likely a result of a recent update you have rolled since then.  My work around to this was by converting the dates in excel to the US format, but is not an ideal solution to have to do each month, especially considering it was working fine until now. I have checked my browser settings and my language is set to English UK, so doesn't look like it's an issue at this end. Can you advise if anything was changed in a recent release that would be causing the issue and if you're looking at a way of setting a default format? Thanks.
Highlighted
Previous Contributor

RE: Set Date by Time Zone

Hi Ben,   Yes there was a  recent change in how dates are handles in an upload.  The behaviour should be that the locale of the browser that uploaded the initial version of the file is used to set the format. If there was a file that didn't have a locale set, then this recent fix resulted in the next version of that file that was uploaded being used to set the locale, so it's possible this is what has happened to cause your change in date format. You can check your locale in Anaplan in the Help>About dialog.    We do also have a feature planned to 'Specify date format when importing data values'. This will be available in one of our upcoming releases.  If you are still having any issues, please contact us at support@anaplan.com. Heather
Highlighted
Previous Contributor

RE: Set Date by Time Zone

Heather, I've followed all this, even to the extent of downloading & reinstalling Chrome, and whilst setting the Spell Check Language to English (United Kingdom) and the Google Chrome Language to English (GB) via the Help tab, the locale setting in Anaplan remains firmly En-US. This is causing a real issue with my personnel data uploads - all loaded from my Mac with dd/mm/yyyy as the default setting, but landing in Anaplan as mm/dd/yyyy.  Is there a way to directly change the locale in Anaplan? Thanks. 
Highlighted
New Contributor

RE: Set Date by Time Zone

Hi Chris, When logged into Anaplan can you click Help>About. This dialog will display which locale Anaplan is picking up from your browser, it should be en-gb to use the UK date format. There is no way to directly change the locale in Anaplan itself. However the locale can be specified if you're using Anaplan Connect to trigger your imports by using the '-locale' command. This can be specifed in your batch or shell script in the set Command line like in the following example: set Command=.\AnaplanClient.bat -locale en_GB %Credentials% -workspace %WorkspaceId% -model %ModelId% %Operation%    It's also worth noting that our next release will include a new feature that allows you to specify a date format when you're importing date values. Iain
Highlighted
Previous Contributor

RE: Set Date by Time Zone

Hi Iain,  Thanks for your note. Anaplan locale is en-us, and remains fixed on this despite changing the (Chrome) browser language to en-gb.  I'll try the Anaplan Connect script and will look forward to the new release with the date fixing feature. Thanks. Chris