TIMESUM syntax error

Highlighted
New Contributor

TIMESUM syntax error

Hi everyone ! 

 

I am currently doing the Level 2 Model Builder, Sprint 1, and I am stuck at step 1.5.7

Basically, I need to feed a boolean Line Item called "Has Data?", which is on the SKU ; Account dimensions from a numeric Line Item called Volumes, which is on SKU ; Account ; FY19 dimension. Therefore, I need to aggregate the data on the time dimension, using a ANY aggregation method to retrieve a boolean value. 

 

Here is how I try to feed "Has Data?":

 

TIMESUM('DAT03 Historic Volumes'.Volumes , , ,ANY)

 

or 

 

TIMESUM('DAT03 Historic Volumes'.Volumes, From, To, ANY)

 

and even

 

TIMESUM('DAT03 Historic Volumes'.Volumes [,] [,] [,ANY])

 

None of these worked, I'm stuck...

 

Here is what I found on Anapedia : 

 

TIMESUM(Line item to aggregate [, Start period] [, End period] [, Aggregation method])

 

Start Period & End Period are non mandatory values according to Anapedia. However, missing intermediate parameters are not permitted. I'm not sure what's that suppose to mean... 

 

Thanks in advance for your kind help ! 

 

Benoît

3 REPLIES 3
Highlighted
Certified Master Anaplanner

Re: TIMESUM syntax error

Hi,

 

If I remember correctly you should just be able to use Timesum('DAT03 Historic Volumes'.Volumes) without any further values and meet the 'Has Data?' flag requirements. Effectively this will just remove the time dimension from the original value and flag the true/false per account for you.

 

Hope this helps!

 

Kind Regards

Adam

Highlighted
New Contributor

Re: TIMESUM syntax error

Thanks @Adam !

 

Here is the formula I used : 

 

Has Data? = IF TIMESUM('DAT03 Historic Volumes'.Volumes) <> 0 THEN TRUE ELSE FALSE

 

It works just fine. 

Highlighted
Super Contributor

Re: TIMESUM syntax error

Hi @Benoit_Martin,

you can skip any optional arguments in the syntax and simply use TIMESUM(Line item to aggregate)