Weird Character in fist column of .csv import

jasnyder1973
Certified Master Anaplanner

Weird Character in fist column of .csv import

I have been noticing on some .csv imports weird characters appearing in the first column of the .csv

When I open in excel or text editor the characters are not there.

Additionally, I seem to be seeing this quite a bit with exports directly from Anaplan.

 

jasnyder1973_0-1628287444225.png

 

6 REPLIES 6
Misbah
Moderator

Re: Weird Character in fist column of .csv import

@jasnyder1973 Which Text encoding option are you using while import?

 

andrewtye
Master Anaplanner/Community Boss

Re: Weird Character in fist column of .csv import

Agree... back in the day had to be very careful about CSV file format. Often found that a manual download from a system would have a slightly different one to an automated one.

If you were to reimport the file brand new (ie call it something else) then the issue should go away.

jasnyder1973
Certified Master Anaplanner

Re: Weird Character in fist column of .csv import

I was using .xls with formatting...I think that I will drop that going forward and take suggestions below.

jackyjoy123
New Contributor

Re: Weird Character in fist column of .csv import

thanks for the awesome information.
MarkWarren
Expert

Re: Weird Character in fist column of .csv import

Sticking to UTF-8 is safest.

naveenmaurya
Occasional Contributor

Re: Weird Character in fist column of .csv import

During the exports of .csv format, there were a lot of these characters coming for me too. I tried this option in the export definition and it works quite well.

naveenmaurya_0-1628561355942.png