You don't have access to submit this form error

Jennifer.labayno@tridant.com
Occasional Contributor

You don't have access to submit this form error

Does any one encounter this type of error? I have a form in NUX where I can add a new item on the list, I don’t have any issue before but then suddenly I’m getting this error.  In Dev model, I’m not having any problem but when I switch to the Prod model, then I encountered this. I have full access and an administrator as well.

Screenshot 2021-05-21 155008.png

12 REPLIES 12
AntonMineev
Certified Master Anaplanner

Hi Jennifer.labayno@tridant.com!

Maybe this directory is of the type "not production"? Then it can be changed only through DEV.

david.savarin
Regular Contributor

I have the same issue and I certainly made sure that the list wasnt production.

I cannot see why this isnt working in deployed mode while everything is working fine in standard mode.

Jennifer.labayno@tridant.com
Occasional Contributor

Hi  david.savarin, 

 

We need this list to be a production list. It is working fine before, I'm not sure what causes this issue suddenly. 

david.savarin
Regular Contributor

Support confirmed me today it s an issue they are aware and working on for a fix
Jennifer.labayno@tridant.com
Occasional Contributor

Hi AntonMineev, 

 

The list is a production list and before it is working fine. Just recently we are receiving this issue. 

rob_marshall
Moderator

Jennifer.labayno@tridant.com @david.savarin 

 

Were there any changes to security?  Check and make sure the Role of the user has access to the list

 

2021-05-24_07-28-25.png

 

Rob

david.savarin
Regular Contributor

Tried that but alas, to no avail.

Triple checked but I am a wa with full access to the model, so it wasnt that either.

 

The issue is definetely tied to forms on deployed mode. It used to work and now it s not working anymore.

 

Support confirmed me today that forms features has an issue they are working on.

For now, support advise to use create action on classic ui.

Misbah
Moderator

@david.savarin 

 

Yes it is a bug on FORMS in deployed mode. Earlier we tested multiple scenarios and here are the results:

 

1. Non Numbered List having a TOP Level instead of Parent: Form Works when you enable "Choose Parent" Option in the New UX 

2. Non Numbered List having a Tope Level instead of Parent: Form doesn't work when you disable "Choose Parent" Option in the New UX & throws an error.

3. Non Numbered List with Parent: Works in all the cases whether you enable or disable "Choose Parent" option in the New UX

4. Numbered List having Top Level instead of Parent: Form doesn't work whether you enable or disable "Choose Parent" option in the New UX.

5. Numbered List with Parent: Form Works in both the cases.

 

Bottomline is:

Non Numbered list with Top Level then go for Option 1

Non Numbered list with Parent - Works anyway

Numbered list with Top Level - Doesn't work

Numbered list with Parent - Works anyway

 

Hope this helps

Misbah

 

AntonMineev
Certified Master Anaplanner

@Misbah thank you so much!

 

I also met this bug, but there was no time to search for a pattern. Clarifying question: "Numbered list with Top Level - Doesn't work" - if the numbered list has a parent hierarchy (for example, Numbered is "L1.2 SKU #" have parent hierarchy "L1.1 Brand". L1.1 have top-level "Total Brand"). Will it work with L1.2 SKU #? Or is it a similar case?