importing data into list item

Takamasa
Occasional Contributor

importing data into list item

Hi!

 

I'm taking a lesson list's course which is before 102 and have a question about  Central Library(list import).

I imported the data of Employees.csv, following the guide, but unlike the guide, error occurred.

So next  I filled in all source blank like photo, then I imported successfully.

Why error occurred regardless of doing same way as the guide?

 

central.PNGcentral 2.PNGcentral 3.PNGcentral 4.PNG

4 ACCEPTED SOLUTIONS

Accepted Solutions
sandeep_bk
Regular Contributor

Hi @Takamasa ,

 

Your imports are failing because of the date format in the property or model time settings. Please review the same and load it again. 

 

Anaplan date import.PNG

 

Also, you can specify which format of the date you trying to load. 

 

 

Hope this helps.

 

Thanks,

Sandeep

View solution in original post

bram.kurstjens
Certified Master Anaplanner

Hi Takamasa,

 

Your first import where you map against name is correct, however Anaplan does not seem to recognize the date format you are importing. You can select the boolean next to start date and leave date (Custom Date Mapping)  and then select the right mapping (M-D-Y). See screenshots below:

image.pngimage.png

Once you have mapped them both correctly, you can run the import.

 

 

KR,

 

Bram Kurstjens

View solution in original post

anirudh
Community Boss

Hi Takamasa,

You do not need to fill in the Code when importing by Name. So the blank is not what is causing the issue here. Please check the Custom Date Mapping checkbox for both Start Date and End Date and use the MMDDYYY  M-D-Y mapping.
Regards,
Anirudh

View solution in original post

bram.kurstjens
Certified Master Anaplanner

Just a quick heads up, the format Takamasa is using is M/D/YYYY, M/DD/YYYY, MM/D/YYYY and MM/DD/YYYY. The fixed format MMDDYYYY will not work for that as it will try to match it with each character as a string. The M/D/Y format as explained in the grey box will be able to deal with single or double digit months/days/years.

View solution in original post

6 REPLIES 6
sandeep_bk
Regular Contributor

Hi @Takamasa ,

 

Your imports are failing because of the date format in the property or model time settings. Please review the same and load it again. 

 

Anaplan date import.PNG

 

Also, you can specify which format of the date you trying to load. 

 

 

Hope this helps.

 

Thanks,

Sandeep

bram.kurstjens
Certified Master Anaplanner

Hi Takamasa,

 

Your first import where you map against name is correct, however Anaplan does not seem to recognize the date format you are importing. You can select the boolean next to start date and leave date (Custom Date Mapping)  and then select the right mapping (M-D-Y). See screenshots below:

image.pngimage.png

Once you have mapped them both correctly, you can run the import.

 

 

KR,

 

Bram Kurstjens

anirudh
Community Boss

Hi Takamasa,

You do not need to fill in the Code when importing by Name. So the blank is not what is causing the issue here. Please check the Custom Date Mapping checkbox for both Start Date and End Date and use the MMDDYYY  M-D-Y mapping.
Regards,
Anirudh

bram.kurstjens
Certified Master Anaplanner

Just a quick heads up, the format Takamasa is using is M/D/YYYY, M/DD/YYYY, MM/D/YYYY and MM/DD/YYYY. The fixed format MMDDYYYY will not work for that as it will try to match it with each character as a string. The M/D/Y format as explained in the grey box will be able to deal with single or double digit months/days/years.
anirudh
Community Boss

Thanks, edited my reply to reflect this!
Takamasa
Occasional Contributor

Thank you so much. I did it!