Required upgrade to Excel add-in version 4.4 and PowerPoint add-in version 1.8

 

The on-premise Anaplan add-ins for Microsoft Office have evolved with a lot of focus on user experience and robustness. As we innovate and expand the reach of Anaplan, the older versions will sunset so that our customers can adopt the newest versions and leverage enhanced performance.  

 

Note: Active users of the Anaplan add-ins have previously been sent email communications with further details directly.

 

What's happening with the old versions of the Excel and PowerPoint add-ins? 

 

The Excel add-ins 4.3 and below, and PowerPoint add-ins 1.6 and 1.7 will become inaccessible shortly after  30 June 2022. From this date, at any point and without notice, the add-ins will stop working and you will not be able to log in to the add-in and refresh your data. 

All customers are required to upgrade to the latest version of the add-ins—Excel 4.4 and PowerPoint 1.8—by the 30 June 2022 deadline. 

 

Updates:  
- Users cannot upgrade directly from deprecated version 2.6 to the Excel Add-in 4.4, you need to upgrade to another version 3 first (3.1/3.2/3.3/3.4). 

 

Why are we deprecating these add-ins? 

We are making changes to a back-end service used by older versions of the add-ins.  

 

Can we push the deadline back? 

This back-end change is critical for other deliverables at Anaplan. Delaying the deprecation could result in potential delays to our roadmap, therefore it is vital that we commit to the June 30th 2022 deadline.  

 

Will these versions be deprecated in the future? 

There are currently no plans to deprecate the latest versions of the add-ins. In the event of this changing, this will be no sooner than 12 months from the date of posting, and will be communicated in advance. 

 

What are the latest versions? 

Excel version 4.4 and PowerPoint version 1.8. You can download these here. 

 

How do I upgrade to the new version? 

 

We recommend taking backup copies of all workbooks before beginning the upgrade process. 

Please note that you cannot upgrade directly from version 3.0 to 4.4; you will need to upgrade to 3.1/3.2/3.3 or 3.4 first.  

If you are using Excel add-in versions 4.0, 4.1, 4.2 or 4.3 

4 series versions are forwards and backwards compatible so no workbook conversion is needed. Simply install version 4.4 and you can work as normal. 

 

If you are using Excel add-in versions 3.1, 3.2, 3.3, or 3.4 

3 series versions require a workbook conversion when upgrading to version 4.4. When opening a 3.x workbook on version 4.4, you will be prompted to convert the workbook. 

Follow the conversion instructions and ensure you save the converted workbook once complete. Please do also keep a backup copy of your original workbook (the conversion button will also prompt you).

 

Once the conversion is completed you will be able to use this workbook using version 4.4. 

 

If you are using Excel add-in 3.0 

  1. Uninstall Excel add-in 3.0 following standard software uninstallation processes. Please note that depending on your corporate software policy, this may need to be done by your IT department.  
  2. Download the latest Excel add-in here on Anapedia and install the add-in. Please note that depending on your corporate software policy, this may need to be done by your IT department. 
  3. Take a copy of your workbook. The add-in is not backwards compatible. Once you open your workbook in the latest Excel add-in, you will not be able to open it again in Excel add-in 3.0. 
  4. Open the copy and refresh it with the latest Excel add-in. 
  5. Check that everything has updated correctly and save your copy. Alternatively, you can also refresh your data in your initial workbook now that it is safe to do so. 

If you are using PowerPoint add-in 1.6 or 1.7 

  1. Uninstall the PowerPoint add-in following standard software uninstallation processes. Please note that depending on your corporate software policy, this may need to be done by your IT department.  
  2. Download the latest PowerPoint add-in here on Anapedia and install the add-in. Please note that depending on your corporate software policy, this may need to be done by your IT department. 
  3. Take a copy of your slide deck. The add-in is not backwards compatible. Once you open your slide deck in the latest PowerPoint add-in, you will not be able to open it again in PowerPoint add-in v1.4. 
  4. Open the copy and refresh it with the latest PowerPoint add-in. 
  5. Check that everything has updated correctly and save your copy. Alternatively, you can also refresh your data in your initial slide deck now that it is safe to do so. 

 

Please note that the latest PowerPoint add-in is not backwards compatible. This means that once you open your PowerPoint document in the latest PowerPoint add-in, you will not be able to open it again in v1.4. We recommend you create a copy of your document first before opening it in the latest PowerPoint add-in. To finish the migration, uninstall the old PowerPoint add-in. 

 

Can I face issues when upgrading? 

Number 

Name 

Versions impacted 

Description 

Mitigation / workaround 

1 

Row shift 

Excel add-in versions 3.0, 3.1, 3.2, 3.3 

Upgrading will cause all data to be shifted down one row. Any external workbook references will have to be updated as the formulas will no longer work. 

Open all workbooks linked to Anaplan data at once and refresh the data when all are open: this will ensure the formulae are automatically updated. 

2 

Customer upgrade process 

Excel add-in 3.0 

IT teams need to install the prerequisites and sometimes package the add-in for all users 

Please work with your IT team and Customer Success Business Partner to manage the transition 

3 

PowerPoint ‘ghost’ installation 

PPT 1.6, 1.7 

When installing a later version of our PowerPoint Add-in, if a machine has both 1.6 and 1.7  installed, you will be left in a state where both programs exist in your list of programs but neither function and you will also be unable to uninstall 1.6. 

Uninstall all versions of the PPT add-in before downloading and installing PPT 1.8. Further details available here. 

4 

Elevated privileges required for PPT add-in install 

PPT 1.6, 1.7 

For version 1.8 of the PowerPoint Add-in elevated privileges are required to install the add-in through command line and for the "all users" option. 

Details of how to workaround this are provided here. 

5 

Anti-virus scanners returning a false positive during installation 

All versions 

Some anti-virus applications incorrectly flag the add-ins and block/quarantine our .xll files from the installation folder. 

Please work with your Security or IT teams to allow the quarantined or blocked .xll files from us. 

 

In all cases, if you are facing issues with the upgrade, please contact Anaplan Support. 

 

What if I don't migrate? 

 

From 30th June 2022, at any point and without notice, the add-ins will stop working and users will not be able to log in to the add-in and refresh their data. 

 

Where can I find more information? 

 

Active users of the Anaplan add-ins have been sent email communications with further details directly. Contact your Anaplan Business Partner for further information, and check out the technical documentation here.

0 Kudos