Invalid Model After Time Range Paste Error

Highlighted
Community Manager

Invalid Model After Time Range Paste Error

This item has been identified as an outstanding known issue as of the March 10, 2018 platform release; a workaround is provided until the issue is officially fixed.

IssueWorkaround

The conditions that cause this issue:

  • The Time Range value for a line item is initially set to “Not Applicable”
  • Pasting into the Time Range cell of the line item in module blueprint view (or in Settings>Modules>Line items) results in the following error message: “Invalid Time Range setting: ‘xxx’”

To correct the invalidity, and avoid data loss, immediately refresh the view and change time settings back manually to “Not Applicable”.

If the line item invalidity is not corrected immediately this may lead to the model becoming invalid and subsequent errors, for example

  • “Sorry, the value on the server has been changed by another user: expected=x, actual=y” when attempting to edit (or paste into) time scale or time range cells.
  • An attempt to open a subsidiary view for an affected line item may result in an error: “An error has occurred on the server”.
  • Copy Model will fail.
  • Model restore may fail.

If any of these errors occur or you suspect that your model may be invalid please contact Anaplan Support immediately for your model to be restored to its last good state.

Tags (1)
Message 1 of 2
1 REPLY 1
Occasional Contributor

Re: Invalid Model After Time Range Paste Error

This issue was fixed in the June 16th, 2018 release.
Message 2 of 2