Anaplan Connect 1.4.1

Frequent Contributor

What is happening?

We are pleased to announce the upcoming release of Anaplan Connect 1.4.1 (AC 1.4.1). This is an upgraded version of Anaplan Connect 1.4 (AC 1.4) which was made generally available in October of 2018. Anaplan Connect 1.4.1 is available for download here.
Please note that AC 1.4.1 does not replace your existing Anaplan Connect installations. You can keep running existing Anaplan Connect installations and install Anaplan Connect 1.4.1 in parallel to a different directory.

Customer Action

We strongly encourage customers using older Anaplan Connect 1.3.x.x versions to move over to Anaplan Connect 1.4.1. Anaplan Connect versions 1.4 and upcoming 1.4.1 support Certificate Authority (CA) certificates in place of Anaplan Certificates. CA Certificates follow industry standards and are more secure as they include a Public key and Private key pair for authentication.

We have provided Anaplan integration users with updated Anaplan Certificates in Q4 of 2018 to provide more time to procure CA Certificates and transition to Anapan Connect 1.4. The updated Anaplan Certificates will expire in 2019, and Anaplan has no plans to provide further updated certificates. Customers must either transition to CA Certificates or switch to Basic Authentication if they choose to continue with older Anaplan Connect 1.3.x.x installations.

We strongly recommend transitioning to Anaplan Connect 1.4 or Anaplan Connect 1.4.1 as soon as possible to avoid integrations issues towards the end of this year. Refer to these blog posts from last year for more information:

What's New: December 8, 2018

Update to Integration Certificate Expiration

Certificate Expiration FAQs

Anaplan Connect 1.4.1 Features

Anaplan Connect 1.4.1 includes the following important feature enhancements and bug fixes:

Features

  • Additional command line parameters to enable users to directly use a CA Private key for authentication. The step for creating a JAVA KeyStore in Anaplan Connect 1.4 is now optional. These changes make it easier for users to use CA certificates. 
  • Anaplan Connect 1.4.1 automatically ignores extra text that appears before the “-----BEGIN CERTIFICATE-----” part in CA Public certificates. Users no longer need to manually edit Public certificates to delete this text.

Bug fixes

Anaplan Connect 1.4.1 fixes these bugs:

  • Anaplan Connect 1.4 displayed NullPointerException error for duplicate rows in the import file and aborted the Import action.
  • Anaplan Connect 1.4 did not recognize some column separators (such as a semicolon).
  • Anaplan Connect 1.4 displayed an error when used with Basic proxy user ID and password. The workaround was to enter dummy text before the user ID and password. With this fix, there is no need to provide the dummy text. Refer to the Anaplan Connect 1.4 release notes for background on this issue: https://community.anaplan.com/t5/Releases/What-s-New-Anaplan-Connect-1-4/ba-p/35452
  • Not all files displayed when unzipping Anaplan Connect 1.4 in a Windows environment.

Support for Oracle Java 11

Anaplan Connect 1.4.1 has been successfully tested against Oracle Java 11. You can install Anaplan Connect 1.4.1 on a Windows or Linux machine with Oracle Java 11 and run your integrations.  To use Java 11, make changes to the following files before running Anaplan Connect 1.4.1 on the indicated operating system:

  • Windows: Modify the AnaplanClient.bat file:
    • Set the JAVA_HOME environment variable to point to your Java 11 installation
    • Comment out parts that check for Java 8. Integration scripts will abort unless this part is commented out. Specifically, comment out the code under the VALIDATE_JAVA_VERSION subroutine.
  • Linux: Modify the AnaplanClient.sh file:
    • Set JAVA_HOME environment variable to point to your Java 11 installation
    • Comment parts that check for Java 8. Integration scripts will abort unless this is commented out. 

Additional Help

Please reach out to your Anaplan Business Partner or Anaplan support team for any Anaplan Connect related queries.