ALM Sync Fails with Internal Error

OwenS
Contributor

ALM Sync Fails with Internal Error

This item has been identified as an outstanding known issue.  A workaround is provided until the issue is officially fixed.

Issue

When trying to perform and ALM sync, it fails with error:

Model Synchronization Failed
An internal error occurred while preparing the structural changes for synchronization. Please contact Anaplan Support.

This can occur when the sync includes the following two changes:

  1. A line item has had the value of the 'Use Switchover' property changed
  2. A new Version has been created

 

Workaround

  1. In your Development model, identify the version(s) which is new in the revision
    1. This can be done by downloading and reviewing the comparison report
  2. Delete this version
  3. Create a new revision tag and sync that to your Production model
  4. In the model history, restore back to before you started the workaround
  5. Create a new revision tag and sync that to your Production model

OR

  1. In your Development model, identify the line item(s) which had the 'Use Switchover' value changed
    1. This can be done by downloading and reviewing the comparison report
  2. Change the 'Use Switchover' value back to its original value
  3. Create a new revision tag and sync that to your Production model
  4. Change the 'Use Switchover' value back to the desired value
  5. Create a new revision tag and sync that to your Production model

 

If this workaround is not suitable in your use case, please contact Support at support@anaplan.com.

 

---

Internal Reference: ALM-1530

0 REPLIES 0