Level1 exam formulas error (activity5)

Mao0511
Occasional Contributor

Level1 exam formulas error (activity5)

I tried to update the formulas but it shows Invalid fomula .

 

Updated formulas for Bonus was below,

IF Employed? THEN Salary * 'EMP 03 Employee Drivers by Role.Bonus %[LOOKUP: 'SYS08 Employee Details'.Department, LOOKUP: 'SYS08 Employee Details'.Country] ELSE 0

Mao0511_0-1613469475945.png

Mao0511_1-1613469778955.pngMao0511_2-1613469891531.png

 

What exactly am I doing wrong here? Any help would be greatly appreciated.

4 REPLIES 4
MarkWarren
Expert

Re: Level1 exam formulas error (activity5)

Hi, if you haven't spotted it already the SYS08 lookup should be to Role not Country

Mao0511
Occasional Contributor

Re: Level1 exam formulas error (activity5)

Thank you for your advice and I tryed it again but still error.

 

The formula for 'EMP02 Employee Expenses'.Bonus is invalid:

Bonus = IF Employed? THEN Salary * EMP03 Employee Drivers by Role''.Bonus %[LOOKUP: 'SYS08 Employee Details'.Department, LOOKUP: 'SYS08 Employee Details'.Role] ELSE 0

Mao0511_0-1613473563182.png

 

MarkWarren
Expert

Re: Level1 exam formulas error (activity5)

Hi, you're right. I didn't spot it. The single quotes here. (and previously there was only a quote at the start of the module name)
EMP03 Employee Drivers by Role''

What I would do when I can't spot it, I copy one I know is working and modify it!

Mao0511
Occasional Contributor

Re: Level1 exam formulas error (activity5)

I solved this issue! Thank you very much!