Level1 exam formulas error (activity5)

Mao0511
Occasional Contributor

Level1 exam formulas error (activity5)

I tried to update the formulas but it shows Invalid fomula .

 

Updated formulas for Bonus was below,

IF Employed? THEN Salary * 'EMP 03 Employee Drivers by Role.Bonus %[LOOKUP: 'SYS08 Employee Details'.Department, LOOKUP: 'SYS08 Employee Details'.Country] ELSE 0

Mao0511_0-1613469475945.png

Mao0511_1-1613469778955.pngMao0511_2-1613469891531.png

 

What exactly am I doing wrong here? Any help would be greatly appreciated.

1 ACCEPTED SOLUTION

Accepted Solutions
MarkWarren
Expert

Hi, you're right. I didn't spot it. The single quotes here. (and previously there was only a quote at the start of the module name)
EMP03 Employee Drivers by Role''

What I would do when I can't spot it, I copy one I know is working and modify it!

View solution in original post

11 REPLIES 11
MarkWarren
Expert

Hi, if you haven't spotted it already the SYS08 lookup should be to Role not Country

Mao0511
Occasional Contributor

Thank you for your advice and I tryed it again but still error.

 

The formula for 'EMP02 Employee Expenses'.Bonus is invalid:

Bonus = IF Employed? THEN Salary * EMP03 Employee Drivers by Role''.Bonus %[LOOKUP: 'SYS08 Employee Details'.Department, LOOKUP: 'SYS08 Employee Details'.Role] ELSE 0

Mao0511_0-1613473563182.png

 

MarkWarren
Expert

Hi, you're right. I didn't spot it. The single quotes here. (and previously there was only a quote at the start of the module name)
EMP03 Employee Drivers by Role''

What I would do when I can't spot it, I copy one I know is working and modify it!

Mao0511
Occasional Contributor

I solved this issue! Thank you very much!

How did you solve this?  Is your list "E3 Role" have a parent hierarchy?  I can not assign a parent hierarchy

 

jackstewartralphlaurencom_0-1626465873647.png

 

I got the formula to not error out but now i am not getting any results as the formula is returning all 0

 

Any help?

 

Here is my formula for the Bonus line item

IF Employed? THEN Salary * 'EMP03 Employee Drivers by Role'.Bonus %[LOOKUP: 'SYS08 Employee Details'.Department, LOOKUP: 'SYS08 Employee Details'.Role] ELSE 0

JaredDolich
Moderator

jack.stewart@ralphlauren.com !!

Great work on EMP02. Your formula is perfect. Nice job swapping in department and role. So if you're still getting zeroes then one of two things are missing. Either the mapping in SYS08 is missing or the Bonus % value in EMP03 is missing. Let's take a look.

SYS08 should look like this - make sure department and Role are populated and are LIST formatted. If role is missing, also make sure you've created the Role List and imported the values correctly:

SYS08_002.png

EMP03 should look like this:

EMP03_001.png


Jared Dolich

Jared,

Thanks for looking into.  I was able to get the formula to populate results.  I also finished the test with a 100.  On to Anaplan Way.

JaredDolich
Moderator

jack.stewart@ralphlauren.com You're a rock star! Nice job. Good luck with TAW. 


Jared Dolich