Highlighted
New Contributor

Level 1 Part 11: Question on Formula Failure

I am working on Part 11 Profit and Loss reports and I am on the part of the activity where I am supposed to add formulas into the REP03 Line Items, but every time I copy and paste the exact formula in it fails with this notification. I have double checked and all of my line items are spelled correctly and there on my DATA01 module. It is giving me this notification for every formula I have to put in for REO03 except for the ones that aren't referencing DATA01. I will attach a photo of my DATA01 module as well. 

 

 

 

Screen Shot 2020-03-25 at 2.50.05 PM.png 

 

 

 

 

Screen Shot 2020-03-25 at 2.16.56 PM.png

3 REPLIES 3
Highlighted
Occasional Contributor

Re: Level 1 Part 11: Question on Formula Failure

Hello,

 

Try using the point and click method instead of typing it out as you might have extra spaces in the source line items or

module name.

 

Use the below formula lists. Don't try to type use copy option

 

IF 'SYS09 Version Details'.Forecast? THEN 'EMP02 Employee Expenses'.Headcount[SUM: 'SYS08 Employee Details'.Country] ELSE 'DATA01 P&L Actuals & Budget'.Headcount
IF 'SYS09 Version Details'.Forecast? THEN 'REV03 Margin Calculation'.Revenue ELSE 'DATA01 P&L Actuals & Budget'.Revenue
IF 'SYS09 Version Details'.Forecast? THEN 'REV03 Margin Calculation'.Cost of Sales ELSE 'DATA01 P&L Actuals & Budget'.Cost of Sales
Revenue - Cost of Sales
Margin / Revenue
IF 'SYS09 Version Details'.Forecast? THEN 'EMP02 Employee Expenses'.Salary[SUM: 'SYS08 Employee Details'.Country] ELSE 'DATA01 P&L Actuals & Budget'.Salary
IF 'SYS09 Version Details'.Forecast? THEN 'EMP02 Employee Expenses'.Bonus[SUM: 'SYS08 Employee Details'.Country] ELSE 'DATA01 P&L Actuals & Budget'.Bonus
IF 'SYS09 Version Details'.Forecast? THEN 'EMP02 Employee Expenses'.Car costs[SUM: 'SYS08 Employee Details'.Country] ELSE 'DATA01 P&L Actuals & Budget'.Car Costs
IF 'SYS09 Version Details'.Forecast? THEN 'EMP02 Employee Expenses'.Phone costs[SUM: 'SYS08 Employee Details'.Country] ELSE 'DATA01 P&L Actuals & Budget'.Phone Costs
IF 'SYS09 Version Details'.Forecast? THEN 'EMP02 Employee Expenses'.Medical costs[SUM: 'SYS08 Employee Details'.Country] ELSE 'DATA01 P&L Actuals & Budget'.Medical Costs
Salary + Bonus + Car Costs + Phone Costs + Medical Costs
IF 'SYS09 Version Details'.Forecast? THEN 'OTH01 Non Employee Expenses'.Shipping costs ELSE 'DATA01 P&L Actuals & Budget'.Shipping Costs
IF 'SYS09 Version Details'.Forecast? THEN 'OTH01 Non Employee Expenses'.Rent ELSE 'DATA01 P&L Actuals & Budget'.Rent
IF 'SYS09 Version Details'.Forecast? THEN 'OTH01 Non Employee Expenses'.Utilities ELSE 'DATA01 P&L Actuals & Budget'.Utillites
IF 'SYS09 Version Details'.Forecast? THEN 'OTH01 Non Employee Expenses'.Shared costs ELSE 'DATA01 P&L Actuals & Budget'.Shared Costs
Shipping Costs + Rent + Utilities + Shared Costs
Margin - Employee Expenses - Other Costs

 

Regards,

Parmod

Highlighted
Contributor

Re: Level 1 Part 11: Question on Formula Failure

Your Module name is 'DATA01 P&L Actuals and Budget' but your formula mentions 'DATA01 P&L Actuals & Budget'.
You are using ampersand instead of and. To avoid such issues, try referencing by clicking on the line item you want to reference (I guess the other solution on this thread is explaining that)

Cheers!

Highlighted
Community Boss

Re: Level 1 Part 11: Question on Formula Failure

@MDaiuto 

 

Follow Point & Click methodology whenever you write any formulae in Anaplan.