Mapping timescale during import and ignoring some columns

Contributor

Mapping timescale during import and ignoring some columns

Hi

I would like to know how do I ignore several columns from the source CSV file while importing data , where the first columns contains list and apart from several columns I want to ignore, Column headers are mapped to time. 

Attaching screen shots for your reference.

In the source file attached , the first column simply maps to the list whereas the next five columns needs to be imported into a different destination and can't be get rid of. After these five columns I need the data to be imported for respective time periods. 

When I map the Time to Column headers, I get an error because of these five columns.

I can't remove these columns from the source file,neither can I map them to a list.

 

Can anyone provide me any solution on how do I get rid of the error. We can change the source file format if necessary but cannot ask the user to upload separate files.

 

Any help would be appreciated

.Source File.PNG

Destination.PNG

Message 1 of 7
6 REPLIES 6
Certified Master Anaplanner

Re: Mapping timescale during import and ignoring some columns

Hi Aakash,

 

I imported a similar file (screenshot below) into an Anaplan module dimensioned by list 1. The columns XYZ and ASD are similar to the columns you want to ignore in your file

 

image.png

 

and the data imported successfully. Here is the mapping I used in the import options:

 

image.png

 

image.png

 

 

The only error I got was the one below (which can be safely ignored)

 

image.png

 

Result after importing

 

image.png

 

Please let me know if this is helpful

 

Regards,

Anirudh

Message 2 of 7
Community Boss

Re: Mapping timescale during import and ignoring some columns

Unfortunately with column headers with time, if you don't map all of the non time columns it will show as an error as @aakash showed

It would be better with two files, but as you said this is not an option, although, you can still add both actions into one process; the user would just have to run a single update, but choose two files as part of that process

David

Message 3 of 7
Contributor

Re: Mapping timescale during import and ignoring some columns

@anirudh
Thanks for the answer , but the users would not normally understand the meaning of the error. That's why I was trying to remove this error.
Message 4 of 7
Certified Master Anaplanner

Re: Mapping timescale during import and ignoring some columns

@aakash 

 

You mentioned that changing file format is an option 

 

Is it possible to unpivot the data file like below 

 

Screen Shot 2019-06-05 at 3.35.13 am.png

 

Then you can import it like 

 

Screen Shot 2019-06-05 at 3.37.51 am.png

 

 

Message 5 of 7
Expert

Re: Mapping timescale during import and ignoring some columns

An alternate option - this is not normally recommended as it makes the import quite brittle - is to set the header row to zero in the file data source. This will cause all mappings to be numbered columns, meaning the columns in the source file must always appear in the same position/order for it to work. As there are no longer any names to match, Anaplan will require you to either map to a time slot or ignore any otherwise unused column.

Message 6 of 7
Contributor

Re: Mapping timescale during import and ignoring some columns

Hi Everyone

 

Thank you so much for your suggestions and solutions. 

 

Aakash

Message 7 of 7