Migrate Anaplan connect from 1.3.3.3 to Anaplan connect 1.4.

Occasional Contributor

Migrate Anaplan connect from 1.3.3.3 to Anaplan connect 1.4.

Hello,

I would like to migrate to Anaplan connect using CA certificate.

In version 1.3.3.3 there is one jar file only.

I used command to execute jar file:

java -jar "anaplan-connect-1-3-3-3.jar" -...commands

 

In version 1.4. there are two files:

when I execute file anaplan-connect-1.4.1.jar

java -jar "anaplan-connect-1.4.1.jar"

there is error message: "no main manifest attribute, in anaplan-connect-1.4.1.jar"

when I execute file anaplan-connect-1.4.1-jar-with-dependencies.jar

java -jar "anaplan-connect-1.4.1-jar-with-dependencies.jar"

there is error message: Error: Could not find or load main class com.anaplan.client

 

I have latest Java 8 Update 201.

 

Could you help me?

Message 1 of 3
2 REPLIES 2
Highlighted
Expert

Re: Migrate Anaplan connect from 1.3.3.3 to Anaplan connect 1.4.

It does indeed look like the jar manifest is incorrect in 1.4. You'll have to work around it by specifying the class directly:

 

java -classpath anaplan-connect-1.4.1-jar-with-dependencies.jar com.anaplan.client.Program ...

 

This is what the AnaplanClient.* launch scripts do.

Note that if you require additional libraries (eg a JDBC driver) then they must be included in the classpath too. On Windows classpath components are separated by semicolons, whereas on other platforms use colons.

Message 2 of 3
Occasional Contributor

Re: Migrate Anaplan connect from 1.3.3.3 to Anaplan connect 1.4.

Thanks Ben,

I moved forward.

I have another ERROR: Server files not found: Server-Files not found for Model-ID=...

 

I use CA certificate now, the same email as before. 

Error message:

9m]←[0;39m ←[35m2188←[0;39m |--   Initializing Service...
←[32mINFO ←[0;39m ←[33m[bstractAuthenticator:←[36m46   ←[0;3
9m]←[0;39m ←[35m2188←[0;39m |--   Authenticating via Certificate...
←[1;31mERROR←[0;39m ←[33m[c.a.client.Program  :←[36m592  ←[0
;39m]←[0;39m ←[35m2188←[0;39m |--   Server files not found: Server-Files not fou
nd for Model-ID=Mymodel (Feign: status 404 reading AnaplanAPI#getServerFiles(
String,String,int); content:
{
  "status": {
    "code": 404,
    "message": "Resource not found"
  }
})

Message 3 of 3