field missing

Highlighted
Contributor

field missing

.  I have two modules with the same dimensions. 

modules.jpg

I’m bring fields into the calculation module from the import module.

 

I’m bring fields into the calculation module from the import module.

 

This works fine for tons but not for percentage distribution.

 module detail.png

module detail2.pngmodule detail3.png

I created a test field and change time scale to year and the values show up (summed for the year 100% or 1):

 test.png

Here is the import module the data is coming from:

 import module.png

 

I can’t find a reason for this to happen and like I said I tried to chat with support but my chat kept getting canceled.

This works fine for tons but not for percentage distribution.

module detail2.pngmodule detail3.png 

I created a test field and change time scale to year and the values show up (summed for the year 100% or 1):

 test.png

Here is the import module the data is coming from:

 import module.png

 

I can’t find a reason for this to happen and like I said I tried to chat with support but my chat kept getting canceled.

Message 1 of 10
9 REPLIES 9
Super Contributor

Re: field missing

Hi Debbie

 

This is really strange.

 

When you go to the cell week 35 and percentage distribution in Grape Program by Week module and do a drill down could you see what is the result or press f8 by selecting the cell.

 

Message 2 of 10
Contributor

Re: field missing

Yes weird....

drill down.PNG

Message 3 of 10
Super Contributor

Re: field missing

Hi Debbie

If you observe carefully the drilldown is pointing towards Actual version than pointing to plan version.

Even am not sure but could you please see your switchover in Versions just to see if that is an issue.
Message 4 of 10
Contributor

Re: field missing

Weird....here is the drill down for the other field from the same module:

drill down2.PNG

Message 5 of 10
Contributor

Re: field missing

and here is the version info

Version.PNG

Why would one come as actual and one as plan....they are coming from the same import 

and how to fix it???

Message 6 of 10
Super Contributor

Re: field missing

Until we have hands on on the system I dont see if I can make a solution.

The easiest work around would be in Grape Program by Week:
1) Delete "Percentag Distribution" Line item
2) Rename the Test Line Item to "Percentage Distribution"
3) Change the time for the line item to weeks from year

Hope this works.
Message 7 of 10
Contributor

Re: field missing

Thanks again for all your help.  Your suggestion did not work but got me to an answer....by changing in blueprint to version not applicable, I get the result i need see pixs below:

noVersion.PNG

noVersion2.PNG

Message 8 of 10
Community Boss

Re: field missing

@debbie5154

I suspect the reason for the zero is that switchover is set to Week 39 (from one of your screen shots) and the line item for Percent Distribution had switchover turned on. I don't know if switchover was turned on for tonnes as well.  If it was, it means the data in the source must be the same for actual and plan version

If the data in the source is zero for percent distribution in the actual version for week 35, it will automatically show up as zero in the target as the data is "Actual"

When the source module contains version and the target module doesn't the "current" version value is used whihc is why the data came through

 

One final thought - Do you actuall y need versions in the target module? - If the data "works" without version, it may be that you can removed versions from the calculation, thus saving 2x the space and calculations

 

I hope that is useful

David

Message 9 of 10
Contributor

Re: field missing

I do believe that you've uncovered the reason Mr. Smith.  Thanks so much for your response.

Message 10 of 10