Anaplan Connect Migration v1.4. SQL Server Connection (check sql server driver for jdbc)

sean_culligan
Certified Master Anaplanner

Anaplan Connect Migration v1.4. SQL Server Connection (check sql server driver for jdbc)

When migrating some Anaplan connect scripts from v1.3. to v1.4. I encountered an error with my sql connection. The error I received when running my script was something like 'check sql server driver for jdbc'. I wanted to share the solution for reference as it was not that obvious.

 

In my original script (v1.3) my connection parameter was:

-jdbcurl jdbc:sqlserver://localhost

 

As you can see in v1.3. I did not provide a port, however when I used the settings in my v1.4. JDBCProperties.properties file:

jdbc.connect.url=jdbc:sqlserver://localhost

 I received an error when running the script. The solution that worked for me was to add the default port value to my connection url as below:

jdbc.connect.url=jdbc:sqlserver://localhost:1433